motherboards
Arctic
Page 1 of 2 1 2 LastLast
Results 1 to 16 of 26

Thread: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

  1. #1
    Member

    Status
    Ryssen is offline

    Last Online
    25-02-2012 @ 17:41
    Join Date
    Jan 2012
    Posts
    28
    CPU: 4 FX-4100 x4 3,6Ghz
    M/B: Asrock 990FX Extreme 4
    RAM: Corsair 8Gb Vengeance 1866Mhz
    GPU: Geforce GTX 560ti
    • Ryssen's Full Spec's
      • Case:
      • Fulltower
      • PSU:
      • Corsair 750w
      • Cooling:
      • Biggest aircoller I could fit
      • Sound:
      • EMU 1212
      • Monitor:
      • HP2207
      • OS:
      • Win7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Points: 323, Level: 3
    Points: 323, Level: 3
    Level completed: 73%,
    Points required for next Level: 27
    Level completed: 73%, Points required for next Level: 27
    Overall activity: 27.0%
    Overall activity: 27.0%

    Default Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    I have tried 3graphic cards ATI HDīs,and they all gave me blackscreen after the startscreen (PSU is 750w Corsair) (Win 7) with the driver installed,without the driver they all boot normal.
    Now I ordered a Geforce 560TI to try....I donīt know how the signal goes from the mother board to the GPU,but maybee theres sommething wrong there..?

  2. #2
    Banned

    Status
    Drdeath is offline

    Last Online
    02-07-2013 @ 01:04
    Join Date
    May 2010
    Location
    Chicago Burbs
    Posts
    8,549
    CPU: Intel Core i7 3930K @ 5GHz
    M/B: ASROCK X79 Extreme 6
    RAM: 16G G.Skill Trident 2400MHz
    GPU: 2 x Radeon 2G 7970 Liquid cooled
    • Drdeath's Full Spec's
      • Case:
      • Phobya CooliT TestBennch
      • PSU:
      • Nexus 1100W
      • Cooling:
      • Custom water. Apogee XT Rev 1, Thermachill TA120.3 plus 120.2, Swiftec Micro res, MCP655
      • Sound:
      • OB
      • Monitor:
      • Viewsonic 27"
      • OS:
      • Win7 64bit
    Thanks
    275
    Thanked 1,022 Times in 880 Posts
    Points: 28,339, Level: 51
    Points: 28,339, Level: 51
    Level completed: 72%,
    Points required for next Level: 311
    Level completed: 72%, Points required for next Level: 311
    Overall activity: 99.9%
    Overall activity: 99.9%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    look for a bios update and see if the fax address this issue.

  3. #3
    Member

    Status
    Ryssen is offline

    Last Online
    25-02-2012 @ 17:41
    Join Date
    Jan 2012
    Posts
    28
    CPU: 4 FX-4100 x4 3,6Ghz
    M/B: Asrock 990FX Extreme 4
    RAM: Corsair 8Gb Vengeance 1866Mhz
    GPU: Geforce GTX 560ti
    • Ryssen's Full Spec's
      • Case:
      • Fulltower
      • PSU:
      • Corsair 750w
      • Cooling:
      • Biggest aircoller I could fit
      • Sound:
      • EMU 1212
      • Monitor:
      • HP2207
      • OS:
      • Win7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Points: 323, Level: 3
    Points: 323, Level: 3
    Level completed: 73%,
    Points required for next Level: 27
    Level completed: 73%, Points required for next Level: 27
    Overall activity: 27.0%
    Overall activity: 27.0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    I have the latest ,1.50 Bios

  4. #4
    Member

    Status
    Ryssen is offline

    Last Online
    25-02-2012 @ 17:41
    Join Date
    Jan 2012
    Posts
    28
    CPU: 4 FX-4100 x4 3,6Ghz
    M/B: Asrock 990FX Extreme 4
    RAM: Corsair 8Gb Vengeance 1866Mhz
    GPU: Geforce GTX 560ti
    • Ryssen's Full Spec's
      • Case:
      • Fulltower
      • PSU:
      • Corsair 750w
      • Cooling:
      • Biggest aircoller I could fit
      • Sound:
      • EMU 1212
      • Monitor:
      • HP2207
      • OS:
      • Win7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Points: 323, Level: 3
    Points: 323, Level: 3
    Level completed: 73%,
    Points required for next Level: 27
    Level completed: 73%, Points required for next Level: 27
    Overall activity: 27.0%
    Overall activity: 27.0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    After trying 5 GPUīs I finaly got it working,It is with a Geforce 560ti. And itīs working so far,donīt know why the others didnīt work,would be nice to know why.

  5. #5
    Core Member

    Status
    realneil is offline

    Last Online
    04-07-2019 @ 19:59
    Join Date
    Sep 2011
    Location
    Virginia, USA
    Posts
    8,433
    CPU: i7-2600K and FX-8350
    M/B: Gigabyte on both
    RAM: 32GB DDR4-3200 and 64GB DDR4-3000
    GPU: 980Ti SLI and RX480 Crossfire
    • realneil's Full Spec's
      • Case:
      • Rosewill Blackhawk Ultra & Rosewill Blackhawk
      • PSU:
      • SeaSonic & Rosewill
      • Cooling:
      • Corsair H80 and Corsair H60, Both with dual high flow, low noise fans added.
      • Sound:
      • both onboard
      • Monitor:
      • ASUS 27" & Acer 28" 4K screen
      • OS:
      • Win-7 64Bit on both
      • Misc:
      • Klipsch Speakers, Plextor DVD Burners on all systems. Third System: Z170 Stinger W/i5-6600K, 16GB DDR4-3000, GTX-980 ViewSonic 27" Screen
    Thanks
    1,451
    Thanked 888 Times in 779 Posts
    Points: 96,357, Level: 96
    Points: 96,357, Level: 96
    Level completed: 66%,
    Points required for next Level: 693
    Level completed: 66%, Points required for next Level: 693
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    Were the AMD cards getting enough power to operate? I know that 750 watts is plenty for most cards, but is your PSU new? Is it known good? Do you have another to test with?
    The problems you described are not typical, especially using AMD Cards on a AMD Motherboard. It should have worked right away.
    That type of result is usually due to faulty power issues.

    What model cards gave you problems?
    Does your BIOS have any settings pertaining to video performance or compatibility?

    Please fill out your system's specs in your profile so we can read them and know better how to help you out.

  6. #6
    Member

    Status
    Ryssen is offline

    Last Online
    25-02-2012 @ 17:41
    Join Date
    Jan 2012
    Posts
    28
    CPU: 4 FX-4100 x4 3,6Ghz
    M/B: Asrock 990FX Extreme 4
    RAM: Corsair 8Gb Vengeance 1866Mhz
    GPU: Geforce GTX 560ti
    • Ryssen's Full Spec's
      • Case:
      • Fulltower
      • PSU:
      • Corsair 750w
      • Cooling:
      • Biggest aircoller I could fit
      • Sound:
      • EMU 1212
      • Monitor:
      • HP2207
      • OS:
      • Win7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Points: 323, Level: 3
    Points: 323, Level: 3
    Level completed: 73%,
    Points required for next Level: 27
    Level completed: 73%, Points required for next Level: 27
    Overall activity: 27.0%
    Overall activity: 27.0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    Yes the PSU is new and is known good.This are the specs.
    Asrock 990FX Extreme 4 FX-4100 x4 3,6Ghz Corsair 8GB Gb
    The cards that didnīt work:
    HD6450
    HD6750
    HD6770
    Geforce 520
    Note that they worked without drivers,did not work with the drivers.
    The above cards are all returned to the seller.
    The card that did work:
    Geforce 650ti

    Does your BIOS have any settings pertaining to video performance or compatibility?
    No only if I have two card,to switch between PCI and PCI-E.
    Last edited by Ryssen; 14-02-2012 at 11:50.

  7. #7
    Core Member

    Status
    realneil is offline

    Last Online
    04-07-2019 @ 19:59
    Join Date
    Sep 2011
    Location
    Virginia, USA
    Posts
    8,433
    CPU: i7-2600K and FX-8350
    M/B: Gigabyte on both
    RAM: 32GB DDR4-3200 and 64GB DDR4-3000
    GPU: 980Ti SLI and RX480 Crossfire
    • realneil's Full Spec's
      • Case:
      • Rosewill Blackhawk Ultra & Rosewill Blackhawk
      • PSU:
      • SeaSonic & Rosewill
      • Cooling:
      • Corsair H80 and Corsair H60, Both with dual high flow, low noise fans added.
      • Sound:
      • both onboard
      • Monitor:
      • ASUS 27" & Acer 28" 4K screen
      • OS:
      • Win-7 64Bit on both
      • Misc:
      • Klipsch Speakers, Plextor DVD Burners on all systems. Third System: Z170 Stinger W/i5-6600K, 16GB DDR4-3000, GTX-980 ViewSonic 27" Screen
    Thanks
    1,451
    Thanked 888 Times in 779 Posts
    Points: 96,357, Level: 96
    Points: 96,357, Level: 96
    Level completed: 66%,
    Points required for next Level: 693
    Level completed: 66%, Points required for next Level: 693
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    The Geforce (GTX?) 560Ti uses more power than those other cards, so I don't know that your issue was power related. I could suggest using "driver sweeper" to remove all of the bits and pieces of old drivers and reinstalling the drivers for the Radeon cards, but if you have that GTX560Ti in and working right, You probably don't care about those old cards anyways! Right?

    I am glad it's working for you now though. Welcome to our site.

  8. #8
    Banned

    Status
    Drdeath is offline

    Last Online
    02-07-2013 @ 01:04
    Join Date
    May 2010
    Location
    Chicago Burbs
    Posts
    8,549
    CPU: Intel Core i7 3930K @ 5GHz
    M/B: ASROCK X79 Extreme 6
    RAM: 16G G.Skill Trident 2400MHz
    GPU: 2 x Radeon 2G 7970 Liquid cooled
    • Drdeath's Full Spec's
      • Case:
      • Phobya CooliT TestBennch
      • PSU:
      • Nexus 1100W
      • Cooling:
      • Custom water. Apogee XT Rev 1, Thermachill TA120.3 plus 120.2, Swiftec Micro res, MCP655
      • Sound:
      • OB
      • Monitor:
      • Viewsonic 27"
      • OS:
      • Win7 64bit
    Thanks
    275
    Thanked 1,022 Times in 880 Posts
    Points: 28,339, Level: 51
    Points: 28,339, Level: 51
    Level completed: 72%,
    Points required for next Level: 311
    Level completed: 72%, Points required for next Level: 311
    Overall activity: 99.9%
    Overall activity: 99.9%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    What you pobably needed to do is wier the old GPU drivers clean in safe mode with a driver cleaner utility.

  9. #9
    Member

    Status
    Ryssen is offline

    Last Online
    25-02-2012 @ 17:41
    Join Date
    Jan 2012
    Posts
    28
    CPU: 4 FX-4100 x4 3,6Ghz
    M/B: Asrock 990FX Extreme 4
    RAM: Corsair 8Gb Vengeance 1866Mhz
    GPU: Geforce GTX 560ti
    • Ryssen's Full Spec's
      • Case:
      • Fulltower
      • PSU:
      • Corsair 750w
      • Cooling:
      • Biggest aircoller I could fit
      • Sound:
      • EMU 1212
      • Monitor:
      • HP2207
      • OS:
      • Win7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Points: 323, Level: 3
    Points: 323, Level: 3
    Level completed: 73%,
    Points required for next Level: 27
    Level completed: 73%, Points required for next Level: 27
    Overall activity: 27.0%
    Overall activity: 27.0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    What you pobably needed to do is wier the old GPU drivers clean in safe mode with a driver cleaner utility.
    I did that,I used Driver sweeper to clean the drivers out.Then I started without drivers and that worked fine.
    Then I installed the drivers and rebooted and I never got past the start screen..

  10. #10
    Banned

    Status
    Drdeath is offline

    Last Online
    02-07-2013 @ 01:04
    Join Date
    May 2010
    Location
    Chicago Burbs
    Posts
    8,549
    CPU: Intel Core i7 3930K @ 5GHz
    M/B: ASROCK X79 Extreme 6
    RAM: 16G G.Skill Trident 2400MHz
    GPU: 2 x Radeon 2G 7970 Liquid cooled
    • Drdeath's Full Spec's
      • Case:
      • Phobya CooliT TestBennch
      • PSU:
      • Nexus 1100W
      • Cooling:
      • Custom water. Apogee XT Rev 1, Thermachill TA120.3 plus 120.2, Swiftec Micro res, MCP655
      • Sound:
      • OB
      • Monitor:
      • Viewsonic 27"
      • OS:
      • Win7 64bit
    Thanks
    275
    Thanked 1,022 Times in 880 Posts
    Points: 28,339, Level: 51
    Points: 28,339, Level: 51
    Level completed: 72%,
    Points required for next Level: 311
    Level completed: 72%, Points required for next Level: 311
    Overall activity: 99.9%
    Overall activity: 99.9%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    Thats odd

  11. #11
    Member

    Status
    Ryssen is offline

    Last Online
    25-02-2012 @ 17:41
    Join Date
    Jan 2012
    Posts
    28
    CPU: 4 FX-4100 x4 3,6Ghz
    M/B: Asrock 990FX Extreme 4
    RAM: Corsair 8Gb Vengeance 1866Mhz
    GPU: Geforce GTX 560ti
    • Ryssen's Full Spec's
      • Case:
      • Fulltower
      • PSU:
      • Corsair 750w
      • Cooling:
      • Biggest aircoller I could fit
      • Sound:
      • EMU 1212
      • Monitor:
      • HP2207
      • OS:
      • Win7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Points: 323, Level: 3
    Points: 323, Level: 3
    Level completed: 73%,
    Points required for next Level: 27
    Level completed: 73%, Points required for next Level: 27
    Overall activity: 27.0%
    Overall activity: 27.0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    Yes thats odd,heres another odd thing for you....I have a trippel installation with Windows and Ubuntu and Mint.And windows is working as it should I canīt access Linux in the normal way,the marker just blinks and nothing happends,I can acces Linux by recovery mode.And if I remove the Geforce card and use a PCI card I can acces Linux as it was ment.
    How am I gonna fix this?

  12. #12
    Moderator

    Status
    vinman is offline

    Last Online
    29-06-2019 @ 11:54
    Join Date
    Feb 2010
    Location
    Los Angeles Orange Cty
    Posts
    4,427
    CPU: Intel Core i7 - 4770K
    M/B: MSI Z87 MPOWER
    RAM: 32 GB DDR3 2400 G.SKILL SNIPER
    GPU: 2X- EVGA GFORCE GTX 960 4GB FTW
    • vinman's Full Spec's
      • Case:
      • Phanteks Enthoo Lux
      • PSU:
      • EVGA SUPERNOVA P2 PLATNIUM 1200W PSU
      • Cooling:
      • AirPlex 360 rad Airplex Pro 240 slim rad Swiftech MCP 655 Pump XSPC RAYSTORM CPU Water Block Monsoon Premium Modular 2 bay Reservoir
      • Sound:
      • On Board
      • Monitor:
      • 27 inch Predator 144 Hz 1440 gaming
      • OS:
      • Win10 PRO 64bit
      • Misc:
      • Razer Black Widow Ultimate KEYBOARD, Razor Death Adder Elite mouse
    Thanks
    1,284
    Thanked 672 Times in 550 Posts
    Points: 74,450, Level: 84
    Points: 74,450, Level: 84
    Level completed: 77%,
    Points required for next Level: 400
    Level completed: 77%, Points required for next Level: 400
    Overall activity: 58.0%
    Overall activity: 58.0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    Are you sure that there is not a bios update for your MB? I had a similar problem and the update fixed it.

  13. #13
    Core Member

    Status
    Irocing is offline

    Last Online
    19-08-2012 @ 22:32
    Join Date
    Oct 2011
    Location
    Arizona (Area 52)
    Posts
    1,755
    CPU: i7 930 Lapped 4.51@1.42 HT ON
    M/B: Asus P6X58D-E
    RAM: Corsair Dominator 6gig 3x2 1600@1723
    GPU: Sapphire 7970 OC Edition 1275/1700/1.200V
    • Irocing's Full Spec's
      • Case:
      • CM 690 II Advanced (Swiss cheezed)
      • PSU:
      • Coolmaster 850 82A Modular
      • Cooling:
      • EK-XT Micro-Rez XSPC 240 X 2 + XSPC 120 MCP 355 pump-600.5
      • Sound:
      • CL SB Titanium/ Bose 2.1
      • Monitor:
      • Samsung 26- 1920x1200
      • OS:
      • Win 7 SP1 HE 64bit
      • Misc:
      • Lamptron FC-2 Lamptron 5 Pole-5v-12v 9- Hi Speed Scythes thru controller Keyboard Logiteck G-15 M4 128g Boot WD 640 Sata III Storage
    Thanks
    29
    Thanked 139 Times in 124 Posts
    Points: 5,047, Level: 20
    Points: 5,047, Level: 20
    Level completed: 99%,
    Points required for next Level: 3
    Level completed: 99%, Points required for next Level: 3
    Overall activity: 25.0%
    Overall activity: 25.0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    Quote Originally Posted by Ryssen View Post
    I did that,I used Driver sweeper to clean the drivers out.Then I started without drivers and that worked fine.
    Then I installed the drivers and rebooted and I never got past the start screen..
    The reason it worked without drivers, Its using the Win native card drivers.

    Something else I always do as to the card drivers along with Audio, ect, is go into the registry.

    If not comfortable there (Don't) , And delete all remnants of previous drivers as to AMD or Nvidia.

    Have used all the un-installers out there and they all leave bits and pieces, even using them in Safe mode.
    Use the find feature in the registry as to location under Software in all sections.
    I know where to look but use it to start.

    I've switched from AMD to Nvidia and back and never had a problem doing it that way.

    Like said, Be careful what you delete there.
    NUF SAID!

    FootNote:
    I remove all ATI or AMD entries,
    BUT, if running a AMD setup as to Board or Cpu don't touch those entries unless
    pertaining to the card.
    While back a couple people went this route as to a problem and when rebooted, Didn't
    Later
    Last edited by Irocing; 15-02-2012 at 16:02.

  14. #14
    Member

    Status
    Ryssen is offline

    Last Online
    25-02-2012 @ 17:41
    Join Date
    Jan 2012
    Posts
    28
    CPU: 4 FX-4100 x4 3,6Ghz
    M/B: Asrock 990FX Extreme 4
    RAM: Corsair 8Gb Vengeance 1866Mhz
    GPU: Geforce GTX 560ti
    • Ryssen's Full Spec's
      • Case:
      • Fulltower
      • PSU:
      • Corsair 750w
      • Cooling:
      • Biggest aircoller I could fit
      • Sound:
      • EMU 1212
      • Monitor:
      • HP2207
      • OS:
      • Win7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Points: 323, Level: 3
    Points: 323, Level: 3
    Level completed: 73%,
    Points required for next Level: 27
    Level completed: 73%, Points required for next Level: 27
    Overall activity: 27.0%
    Overall activity: 27.0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    I have the latest (1.50 Bios).
    Well now I got it working in Linux 2.
    I got the advise to go in recovery mode and install the graphic drivers then reboot and log in the usualway and itīs working now.
    Now there is the linux installation CD that stops halfway with black background and white text.
    Anyone know a fix for this?Otherwise Iīm going to have to use the PCI card when installing Linux....

  15. #15
    New Member

    Status
    jerry is offline

    Last Online
    10-09-2013 @ 05:18
    Join Date
    Sep 2013
    Posts
    6
    Thanks
    6
    Thanked 0 Times in 0 Posts
    Points: 17, Level: 1
    Points: 17, Level: 1
    Level completed: 33%,
    Points required for next Level: 33
    Level completed: 33%, Points required for next Level: 33
    Overall activity: 7.0%
    Overall activity: 7.0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    guys,i have bought this motherboard recently (asrock 990fx extreme 4 ) along with the ram G.Skill RipjawsX DDR3 8 GB (2 x 4 G PC RAM (F3-12800CL9D-8GBXL). Now the board doesnt gives display output monitor led blinks and nothing comes Dr. Debug status shows a digit "54". Is this shows the incompatibility of the ram or he malfunction.? if the ram is incompatible, can u suggest me some gud ram plz.

  16. #16
    Moderator

    Status
    Cyberburnout is offline

    Last Online
    20-10-2017 @ 11:01
    Join Date
    Jul 2012
    Location
    GROVE CITY OHIO
    Posts
    5,362
    CPU: Intel i7-5820k
    M/B: ASRock X99 WS
    RAM: 32GB Crucial DDR4 2133
    GPU: 2 R9-290s Xfire
    • Cyberburnout's Full Spec's
      • Case:
      • Urban T81
      • PSU:
      • CM Silent 350w
      • Cooling:
      • Custom H20, Ek blocks for CPU and GPUs
      • Sound:
      • ONBOARD
      • Monitor:
      • Dual 24"
      • OS:
      • WINDOWS 7 ULTIMATE X64
      • Misc:
      • White LED lighting
    Thanks
    61
    Thanked 1,166 Times in 663 Posts
    Points: 26,323, Level: 49
    Points: 26,323, Level: 49
    Level completed: 78%,
    Points required for next Level: 227
    Level completed: 78%, Points required for next Level: 227
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Maybee theres sommething wrong with my Asrock 990FX Extreme4 boards?

    [QUOTE=jerry;174472]guys,i have bought this motherboard recently (asrock 990fx extreme 4 ) along with the ram G.Skill RipjawsX DDR3 8 GB (2 x 4 G PC RAM (F3-12800CL9D-8GBXL). Now the board doesnt gives display output monitor led blinks and nothing comes Dr. Debug status shows a digit "54". Is this shows the incompatibility of the ram or he malfunction.? if the ram is incompatible, can u suggest me some gud ram plz.[/QUOTE

    What CPU are you using? Are you sure it is compatible with that board and the current bios ver? There is usually a stick on the box saying which bios ver it shipped with. Did you try only 1 stick in slot 1? If the board has a button to clear bios then clear it and try again. But most time this error is related to CPUs. The memory controller is on the cpu die. So if you have another CPU to test the board with do so. Or try your current cpu in another board that is known to work.

    Most likely it is related to the cpu.
    "If you got it, Build it"

    A+ Certified. Dell, Lenovo, HP, Lexmarks, Xerox, Panasonic and NEC Certified ASP.

  17. The following user thanks Cyberburnout For this above post:

    jerry (08-09-2013)

Page 1 of 2 1 2 LastLast

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 1
    Last Post: 24-01-2012, 19:34
  2. ASRock X79 Extreme4-M
    By Skyguy in forum Reviews & Articles
    Replies: 4
    Last Post: 24-12-2011, 20:58
  3. ASRock Z68 Extreme4
    By Skyguy in forum Reviews & Articles
    Replies: 7
    Last Post: 14-06-2011, 17:43
  4. ASRock 990FX Extreme4 AM3+ Bulldozer motherboard
    By Lil' ― Dead in forum AMD
    Replies: 2
    Last Post: 24-05-2011, 02:42
  5. ASRock 890GX Extreme4
    By Skyguy in forum Reviews & Articles
    Replies: 6
    Last Post: 10-09-2010, 09:55

Search tags for this page

asrock 990fx extreme 4 problem posting
,
asrock 990fx extreme4 bios no video
,

asrock 990fx extreme4 graphics card

,

asrock 990fx extreme4 issues

,

asrock 990fx extreme4 linux

,
asrock 990fx extreme4 no video
,

asrock 990fx extreme4 problems

,

asrock 990fx extreme4 video output

,

asrock 990fx linux

,

asrock 990fx no sound

,
asrock fx990 extreme4 board with linux
,

debian asrock 990fx extreme4

,

linux asrock 990fx extreme4

,

problems installing graphics card on asrock 990fx extreme 4

Click on a term to search for related topics.

Tags for this Thread