motherboards
Arctic
Arctic Feezer 7x
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 16 of 49

Thread: My Corsair H100 died

  1. #1
    Regular Member

    Status
    ~LL~ is offline

    Last Online
    08-01-2015 @ 03:36
    Join Date
    Jan 2010
    Location
    Christchurch New Zealand
    Posts
    232
    CPU: Intel i7 2600K D2
    M/B: Gigabyte GA-Z68X-UD7-B3
    RAM: 16Gb G.Skill Sniper 1600MHz 7-8-7-24-2N 1.60V
    GPU: 2 x Sapphire HD7970 3Gb Crossfire
    • ~LL~'s Full Spec's
      • Case:
      • Corsair 800D
      • PSU:
      • Silverstone Strider Gold 1200W
      • Cooling:
      • Corsair H100 Extreme Closed Loop H2O 7 Zalman 120mm Case fans
      • Monitor:
      • Dell U3011 30" IPS monitor
      • OS:
      • Windows 7 64Bit
    Thanks
    18
    Thanked 39 Times in 28 Posts
    Points: 5,819, Level: 22
    Points: 5,819, Level: 22
    Level completed: 54%,
    Points required for next Level: 231
    Level completed: 54%, Points required for next Level: 231
    Overall activity: 0%
    Overall activity: 0%

    Default My Corsair H100 died

    and it's only a couple of weeks old.

    What's even more annoying is that is seems to be a known issue having read the Corsair forums. Being an import for me I'm going to have to RMA it directly with Corsair, frustrating!

    So what has happened is last night I noticed that a fan was speeding up then slowing down, but on investigation it was actually starting and stopping, not randomly but cyclically. I also noted that the three step phase change LED's were not working, nor was the phase change button. But wait..........there's more.............

    Not only is the fan 3 stage change button or system not working I also realised that of the four fan sockets only 1 is providing constant power. as you look at the unit from above the two on the left are completely dead, the next one is the one that starts then stops and the one on the far right provides constant power, but only at full noise.

    I've changed the molex to make sure it wasn't a power issue (a brand new Strider 1200 Gold) and tried to reset it following the Corsair forum's instructions, with no luck.

    God I have had so many failures these last two months, I have literally replaced my whole system due to failures, motherboard, GPU's, PSU, RAM.....grrrrrrrr.

  2. #2
    Regular Member

    Status
    rrplay is offline

    Last Online
    29-11-2016 @ 15:20
    Join Date
    Dec 2010
    Location
    Crystal Lake,IL
    Posts
    483
    CPU: AMD FX-8350
    M/B: Asus Sabertooth 990FX
    RAM: G.Skill Ripjaws 1866 2@4GB
    GPU: PoweColor (AMD) Fury X 4GB
    • rrplay's Full Spec's
      • Case:
      • Cooler Master HAF-X
      • PSU:
      • Cooler Master 1000W
      • Cooling:
      • Phanteks PH-TC14PE
      • Sound:
      • Onboard Audio / Spks Planar PM 9's
      • Monitor:
      • Asus VH238H@2
      • OS:
      • Windows 7 SP2
      • Misc:
      • Thermaltake Poseidon Z [Brown switches -mod] Func M2 Game Mouse and Func pad
    Thanks
    205
    Thanked 65 Times in 51 Posts
    Points: 7,233, Level: 25
    Points: 7,233, Level: 25
    Level completed: 37%,
    Points required for next Level: 317
    Level completed: 37%, Points required for next Level: 317
    Overall activity: 0%
    Overall activity: 0%

    Default Re: My Corsair H100 died

    Sorry to hear that .Bummer ..talk about a string of some bad luck with hardware.I feel your pain.
    "You're never to old to learn something stupid."

  3. #3
    Regular Member

    Status
    4hams is offline

    Last Online
    10-02-2014 @ 17:40
    Join Date
    Aug 2009
    Location
    Toronto
    Posts
    1,200
    CPU: Intel Core i7 920
    M/B: ASUS
    RAM: G.SKILL
    GPU: ATI RADEON
    • 4hams's Full Spec's
      • Case:
      • CM
      • PSU:
      • Seasonic
      • Cooling:
      • CORSAIR H50
      • Sound:
      • Onboard 8.1 HD
      • Monitor:
      • Hanns.G 22"
      • OS:
      • Windows 7 Pro 64 Bit
      • Misc:
      • It works!
    Thanks
    650
    Thanked 177 Times in 139 Posts
    Points: 7,881, Level: 26
    Points: 7,881, Level: 26
    Level completed: 56%,
    Points required for next Level: 269
    Level completed: 56%, Points required for next Level: 269
    Overall activity: 0%
    Overall activity: 0%

    Default Re: My Corsair H100 died

    Sorry to hear about the troubles Chris.
    On an old Q9550 build I had similar issue. Blew a Coolermaster fan that had a switch for the lighing then realised I had blown 2 fan headers on the ASUS P5Q motherboard and subsequently blew 3 500 GB barracudas and 2 60 GB Vertex SSD's. Eventually narrowed it down to the Enermax Power supply power spiking on shut down.

    I feel your pain Chris! And just so ya know I had a H50 go south on me about 2 months ago and replaced it with an ECO 240 which is running well!

  4. #4
    OC Jedi Padawan

    Status
    smduff is offline

    Last Online
    06-02-2016 @ 22:51
    Join Date
    Aug 2009
    Location
    British Columbia, Canada
    Posts
    2,372
    CPU: AMD Phenom II X6 1055T@4GHz
    M/B: ASUS Crosshair V Formula
    RAM: 4 Gigs Mushkin 1600MHz
    GPU: VisionTek AMD Radeon 6970
    • smduff's Full Spec's
      • Case:
      • Danger Den Tower 21 Black Series
      • PSU:
      • Sentey GOLD 1000W
      • Cooling:
      • Custom Water- EK Supreme HF EK X360 Rad DD 5970 Block MCP655 6X Ultra Kaze 3000rpm 133.4cfm
      • Monitor:
      • LG Flatron 19"
      • OS:
      • Windows 7 Ultimate 64bit
    Thanks
    109
    Thanked 518 Times in 476 Posts
    Points: 17,345, Level: 40
    Points: 17,345, Level: 40
    Level completed: 12%,
    Points required for next Level: 705
    Level completed: 12%, Points required for next Level: 705
    Overall activity: 0%
    Overall activity: 0%

    Default Re: My Corsair H100 died

    Sorry to hear it m8, when is the service?

  5. #5
    Core Member

    Status
    alan1476 is offline

    Last Online
    11-04-2018 @ 20:32
    Join Date
    Jan 2010
    Location
    USA -The gangsta state- Die Proud
    Posts
    1,508
    CPU: Intel 3960X REV7 C2
    M/B: Asus Sabertooth X79
    RAM: 32 gb Kingston Hyper X SDRAM DDR3 2133/fans
    GPU: Asus Matrix 290X ROG
    • alan1476's Full Spec's
      • Case:
      • Corsair Obsidian 800D
      • PSU:
      • Corsair 1200W AX
      • Cooling:
      • Swiftech H20-330 Edge Kit Cooling ( need new water block) 2x HyperX RAM Fans
      • Sound:
      • ASUS PCI-Express x1 Sound Card XONAR ESSENCE STX/90-
      • Monitor:
      • Triple Samsungs ( Digital Tiger)
      • OS:
      • Windows 7 64bit Ultimate SP1
      • Misc:
      • Build 2 - Corsair Obsidian 650D Asrock Z87 Fatal1ty One Professional Intel 4770K CPU 16gbs of Ripjaws Z 2133mhz with fans Coolit ECO A.L.C. 240mm Rad EVGA 780Ti Classified (not installed yet} Seasonic 1200W Platnium Third and forth build specs on request
    Thanks
    560
    Thanked 131 Times in 107 Posts
    Points: 14,794, Level: 36
    Points: 14,794, Level: 36
    Level completed: 93%,
    Points required for next Level: 56
    Level completed: 93%, Points required for next Level: 56
    Overall activity: 41.0%
    Overall activity: 41.0%

    Default Re: My Corsair H100 died

    I was just about to buy one also. Maybe it was just a bad unit.

    "A lawyer with his briefcase can steal more than a hundred men with guns."

  6. #6
    Banned

    Status
    Doctor_Death is offline

    Last Online
    25-02-2016 @ 11:04
    Join Date
    Apr 2008
    Location
    Punxsutawney, Pa. - USA
    Posts
    11,789
    CPU: Core i7 3930K
    M/B: ASRock X79 Extreme9
    RAM: 64GBs Kingston Beast 2133MHz
    GPU: Two EVGA GTX 690s in Quad SLI
    • Doctor_Death's Full Spec's
      • Case:
      • Corsair 900D
      • PSU:
      • Corsair AX1200i
      • Cooling:
      • Complete system cooled by EK Water Blocks
      • Sound:
      • Creative Sound Core 3D Audio 7.1
      • Monitor:
      • Dell U3011 30" 2560 x 1600 Res
      • OS:
      • Win 7 Ultimate 64Bit
      • Misc:
      • Asus Blu-Ray, Asus 24X DVD Burner, Max Mechanicalkeyboard / Razer Abyssus Mouse / Razer eXact Mat with wrist rest.
    Thanks
    339
    Thanked 2,582 Times in 1,551 Posts
    Points: 490,204, Level: 100
    Points: 490,204, Level: 100
    Level completed: 0%,
    Points required for next Level: 0
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Overall activity: 0%

    Default Re: My Corsair H100 died

    Alan, are you sure it's not that fan's you used? I have two H100s here both with 4 fan setups running on high speed, and I am not having any problems. What case are you using this with the 650D ? You might want to wait and buy the AESTEK Super Cooler when it's released, the Rad is twice as thick, and it comes with 4 fans.

  7. The following user thanks Doctor_Death For this above post:

    4hams (17-09-2011)

  8. #7
    Regular Member

    Status
    Bob2701 is offline

    Last Online
    17-06-2018 @ 13:44
    Join Date
    Feb 2010
    Location
    New Jersey
    Posts
    2,005
    CPU: Intel i7 4970K
    M/B: ASUS Z97 Maximus Hero
    RAM: G.Skill Trident 16gb
    GPU: Radeon R9 270 X2
    • Bob2701's Full Spec's
      • Case:
      • Corsair 800D
      • PSU:
      • beQuiet PowerZone 1000
      • Cooling:
      • XSPC Custom Water Cooled
      • Monitor:
      • ASUS 24" 3D
      • OS:
      • Windows 7 Ultimate 64bit
      • Misc:
      • BitFenix Recon Fan Controller
    Thanks
    1,100
    Thanked 305 Times in 269 Posts
    Points: 11,280, Level: 32
    Points: 11,280, Level: 32
    Level completed: 5%,
    Points required for next Level: 670
    Level completed: 5%, Points required for next Level: 670
    Overall activity: 0%
    Overall activity: 0%

    Default Re: My Corsair H100 died

    Not good news. I just bought the H100 and I hope it was just a fluke.

  9. #8
    Core Member

    Status
    alan1476 is offline

    Last Online
    11-04-2018 @ 20:32
    Join Date
    Jan 2010
    Location
    USA -The gangsta state- Die Proud
    Posts
    1,508
    CPU: Intel 3960X REV7 C2
    M/B: Asus Sabertooth X79
    RAM: 32 gb Kingston Hyper X SDRAM DDR3 2133/fans
    GPU: Asus Matrix 290X ROG
    • alan1476's Full Spec's
      • Case:
      • Corsair Obsidian 800D
      • PSU:
      • Corsair 1200W AX
      • Cooling:
      • Swiftech H20-330 Edge Kit Cooling ( need new water block) 2x HyperX RAM Fans
      • Sound:
      • ASUS PCI-Express x1 Sound Card XONAR ESSENCE STX/90-
      • Monitor:
      • Triple Samsungs ( Digital Tiger)
      • OS:
      • Windows 7 64bit Ultimate SP1
      • Misc:
      • Build 2 - Corsair Obsidian 650D Asrock Z87 Fatal1ty One Professional Intel 4770K CPU 16gbs of Ripjaws Z 2133mhz with fans Coolit ECO A.L.C. 240mm Rad EVGA 780Ti Classified (not installed yet} Seasonic 1200W Platnium Third and forth build specs on request
    Thanks
    560
    Thanked 131 Times in 107 Posts
    Points: 14,794, Level: 36
    Points: 14,794, Level: 36
    Level completed: 93%,
    Points required for next Level: 56
    Level completed: 93%, Points required for next Level: 56
    Overall activity: 41.0%
    Overall activity: 41.0%

    Default Re: My Corsair H100 died

    Quote Originally Posted by Doctor_Death View Post
    Alan, are you sure it's not that fan's you used? I have two H100s here both with 4 fan setups running on high speed, and I am not having any problems. What case are you using this with the 650D ? You might want to wait and buy the AESTEK Super Cooler when it's released, the Rad is twice as thick, and it comes with 4 fans.
    Stan, I dont even own one, this is ~LL~s thread, he is having the problems not me.

    "A lawyer with his briefcase can steal more than a hundred men with guns."

  10. #9
    OC Jedi Master

    Status
    Deton is offline

    Last Online
    27-02-2014 @ 22:13
    Join Date
    Dec 2006
    Location
    Canada
    Posts
    8,493
    CPU: i7 920, 4.2Ghz HT
    M/B: P6X58D Premium
    RAM: OCZ Flex EX PC3-17000 12GB
    GPU: Asus EAH5870
    • Deton's Full Spec's
      • Case:
      • Lian Li A70F
      • PSU:
      • Enermax Galaxy Evo 1250W
      • Cooling:
      • Custom H20 setup.
      • Sound:
      • Onboard
      • Monitor:
      • ViewSonic VX2435
      • OS:
      • Win 7 - 64bit
    Thanks
    45
    Thanked 1,179 Times in 1,026 Posts
    Points: 50,246, Level: 69
    Points: 50,246, Level: 69
    Level completed: 36%,
    Points required for next Level: 904
    Level completed: 36%, Points required for next Level: 904
    Overall activity: 7.0%
    Overall activity: 7.0%

    Default Re: My Corsair H100 died

    Alan, excuse the oldie sometime he forget who he talking to

    You're all know sometime you get a bad apple in a basket.

  11. #10
    Member

    Status
    Ghzsystems is offline

    Last Online
    17-10-2011 @ 17:24
    Join Date
    Feb 2010
    Location
    Sherwood, Oregon
    Posts
    56
    CPU: I7-960 HT @ 4.2GHZ
    M/B: Asus P6T
    RAM: Corsair Vengeance/1600mhz
    GPU: EVGA/GTX570/1280MB
    • Ghzsystems's Full Spec's
      • Case:
      • Cooler Master/932
      • PSU:
      • Cosair/TX850/850W
      • Cooling:
      • Cooler Master H70 (Reversed fans)
      • OS:
      • Windows 7 Ultimate SP1 x64
    Thanks
    7
    Thanked 1 Time in 1 Post
    Points: 1,526, Level: 10
    Points: 1,526, Level: 10
    Level completed: 88%,
    Points required for next Level: 24
    Level completed: 88%, Points required for next Level: 24
    Overall activity: 2.0%
    Overall activity: 2.0%

    Default Re: My Corsair H100 died

    Quote Originally Posted by ~LL~ View Post
    and it's only a couple of weeks old.

    What's even more annoying is that is seems to be a known issue having read the Corsair forums. Being an import for me I'm going to have to RMA it directly with Corsair, frustrating!

    So what has happened is last night I noticed that a fan was speeding up then slowing down, but on investigation it was actually starting and stopping, not randomly but cyclically. I also noted that the three step phase change LED's were not working, nor was the phase change button. But wait..........there's more.............

    Not only is the fan 3 stage change button or system not working I also realised that of the four fan sockets only 1 is providing constant power. as you look at the unit from above the two on the left are completely dead, the next one is the one that starts then stops and the one on the far right provides constant power, but only at full noise.

    I've changed the molex to make sure it wasn't a power issue (a brand new Strider 1200 Gold) and tried to reset it following the Corsair forum's instructions, with no luck.

    God I have had so many failures these last two months, I have literally replaced my whole system due to failures, motherboard, GPU's, PSU, RAM.....grrrrrrrr.
    Can I ask where you are buying from? Maybe your getting shady parts from a shady dealer at better than normal prices?

  12. #11
    Regular Member

    Status
    ~LL~ is offline

    Last Online
    08-01-2015 @ 03:36
    Join Date
    Jan 2010
    Location
    Christchurch New Zealand
    Posts
    232
    CPU: Intel i7 2600K D2
    M/B: Gigabyte GA-Z68X-UD7-B3
    RAM: 16Gb G.Skill Sniper 1600MHz 7-8-7-24-2N 1.60V
    GPU: 2 x Sapphire HD7970 3Gb Crossfire
    • ~LL~'s Full Spec's
      • Case:
      • Corsair 800D
      • PSU:
      • Silverstone Strider Gold 1200W
      • Cooling:
      • Corsair H100 Extreme Closed Loop H2O 7 Zalman 120mm Case fans
      • Monitor:
      • Dell U3011 30" IPS monitor
      • OS:
      • Windows 7 64Bit
    Thanks
    18
    Thanked 39 Times in 28 Posts
    Points: 5,819, Level: 22
    Points: 5,819, Level: 22
    Level completed: 54%,
    Points required for next Level: 231
    Level completed: 54%, Points required for next Level: 231
    Overall activity: 0%
    Overall activity: 0%

    Default Re: My Corsair H100 died

    Quote Originally Posted by Ghzsystems View Post
    Can I ask where you are buying from? Maybe your getting shady parts from a shady dealer at better than normal prices?

    I live in NZ and purchased it from a Corsair registered reseller in Australia as none were available in NZ. The company is a reputable company who I have dealt with before.

    The fans I was using were the supplied fans with the unit and they were the only two plugged into the sockets of the cooler. When you read the corsair forums I have read numerous threads where others have had exactly the same problem as I have had and specifically with the H100. From reading these it is clearly obvious this is an ongoing known problem (the Corsair staff are responding in the threads). Questions have been asked why are they shipping units without fixing the issues.

    Anyway, at leats the pump is still working so I'm running my fans from the motherboard instead - noisy but keeping me cool.

  13. The following users thank 2 For this above post:

    4hams (18-09-2011), Bob2701 (18-09-2011)

  14. #12
    OC Jedi Master

    Status
    Deton is offline

    Last Online
    27-02-2014 @ 22:13
    Join Date
    Dec 2006
    Location
    Canada
    Posts
    8,493
    CPU: i7 920, 4.2Ghz HT
    M/B: P6X58D Premium
    RAM: OCZ Flex EX PC3-17000 12GB
    GPU: Asus EAH5870
    • Deton's Full Spec's
      • Case:
      • Lian Li A70F
      • PSU:
      • Enermax Galaxy Evo 1250W
      • Cooling:
      • Custom H20 setup.
      • Sound:
      • Onboard
      • Monitor:
      • ViewSonic VX2435
      • OS:
      • Win 7 - 64bit
    Thanks
    45
    Thanked 1,179 Times in 1,026 Posts
    Points: 50,246, Level: 69
    Points: 50,246, Level: 69
    Level completed: 36%,
    Points required for next Level: 904
    Level completed: 36%, Points required for next Level: 904
    Overall activity: 7.0%
    Overall activity: 7.0%

    Default Re: My Corsair H100 died

    Quote Originally Posted by ~LL~ View Post

    From reading these it is clearly obvious this is an ongoing known problem (the Corsair staff are responding in the threads). Questions have been asked why are they shipping units without fixing the issues.

    geezzz...then it's more than one bad apple, perhaps the manufacture decides to cut corner at the last minute to meet the production quota???

    What's Corsair respond on this matter?

  15. #13
    Regular Member

    Status
    ~LL~ is offline

    Last Online
    08-01-2015 @ 03:36
    Join Date
    Jan 2010
    Location
    Christchurch New Zealand
    Posts
    232
    CPU: Intel i7 2600K D2
    M/B: Gigabyte GA-Z68X-UD7-B3
    RAM: 16Gb G.Skill Sniper 1600MHz 7-8-7-24-2N 1.60V
    GPU: 2 x Sapphire HD7970 3Gb Crossfire
    • ~LL~'s Full Spec's
      • Case:
      • Corsair 800D
      • PSU:
      • Silverstone Strider Gold 1200W
      • Cooling:
      • Corsair H100 Extreme Closed Loop H2O 7 Zalman 120mm Case fans
      • Monitor:
      • Dell U3011 30" IPS monitor
      • OS:
      • Windows 7 64Bit
    Thanks
    18
    Thanked 39 Times in 28 Posts
    Points: 5,819, Level: 22
    Points: 5,819, Level: 22
    Level completed: 54%,
    Points required for next Level: 231
    Level completed: 54%, Points required for next Level: 231
    Overall activity: 0%
    Overall activity: 0%

    Default Re: My Corsair H100 died

    Quote Originally Posted by Deton View Post
    geezzz...then it's more than one bad apple, perhaps the manufacture decides to cut corner at the last minute to meet the production quota???

    What's Corsair respond on this matter?
    Their response is basically to just RMA them - but it doesn't fix the underlying issue.

    Examples of issue here:

    http://forum.corsair.com/v3/showthread.php?t=98317
    http://forum.corsair.com/v3/showthread.php?t=97977
    http://forum.corsair.com/v3/showthread.php?t=97287

  16. #14
    Banned

    Status
    Doctor_Death is offline

    Last Online
    25-02-2016 @ 11:04
    Join Date
    Apr 2008
    Location
    Punxsutawney, Pa. - USA
    Posts
    11,789
    CPU: Core i7 3930K
    M/B: ASRock X79 Extreme9
    RAM: 64GBs Kingston Beast 2133MHz
    GPU: Two EVGA GTX 690s in Quad SLI
    • Doctor_Death's Full Spec's
      • Case:
      • Corsair 900D
      • PSU:
      • Corsair AX1200i
      • Cooling:
      • Complete system cooled by EK Water Blocks
      • Sound:
      • Creative Sound Core 3D Audio 7.1
      • Monitor:
      • Dell U3011 30" 2560 x 1600 Res
      • OS:
      • Win 7 Ultimate 64Bit
      • Misc:
      • Asus Blu-Ray, Asus 24X DVD Burner, Max Mechanicalkeyboard / Razer Abyssus Mouse / Razer eXact Mat with wrist rest.
    Thanks
    339
    Thanked 2,582 Times in 1,551 Posts
    Points: 490,204, Level: 100
    Points: 490,204, Level: 100
    Level completed: 0%,
    Points required for next Level: 0
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Overall activity: 0%

    Default Re: My Corsair H100 died

    LL, this is what I found in the Corsair forums, as far as problems with the H100, and the Ram Guy gives a fix to try before asking for RMA. Here's screen shot from the forums, have you tried the fix ?


    My Corsair H100 died-h100-problems-corsair-forums.jpg
    Last edited by Doctor_Death; 18-09-2011 at 07:51.

  17. #15
    Core Member

    Status
    alan1476 is offline

    Last Online
    11-04-2018 @ 20:32
    Join Date
    Jan 2010
    Location
    USA -The gangsta state- Die Proud
    Posts
    1,508
    CPU: Intel 3960X REV7 C2
    M/B: Asus Sabertooth X79
    RAM: 32 gb Kingston Hyper X SDRAM DDR3 2133/fans
    GPU: Asus Matrix 290X ROG
    • alan1476's Full Spec's
      • Case:
      • Corsair Obsidian 800D
      • PSU:
      • Corsair 1200W AX
      • Cooling:
      • Swiftech H20-330 Edge Kit Cooling ( need new water block) 2x HyperX RAM Fans
      • Sound:
      • ASUS PCI-Express x1 Sound Card XONAR ESSENCE STX/90-
      • Monitor:
      • Triple Samsungs ( Digital Tiger)
      • OS:
      • Windows 7 64bit Ultimate SP1
      • Misc:
      • Build 2 - Corsair Obsidian 650D Asrock Z87 Fatal1ty One Professional Intel 4770K CPU 16gbs of Ripjaws Z 2133mhz with fans Coolit ECO A.L.C. 240mm Rad EVGA 780Ti Classified (not installed yet} Seasonic 1200W Platnium Third and forth build specs on request
    Thanks
    560
    Thanked 131 Times in 107 Posts
    Points: 14,794, Level: 36
    Points: 14,794, Level: 36
    Level completed: 93%,
    Points required for next Level: 56
    Level completed: 93%, Points required for next Level: 56
    Overall activity: 41.0%
    Overall activity: 41.0%

    Default Re: My Corsair H100 died

    I am happy you still dont think I am having bad fan problems with the H-100 that I dont own, but you can send me yours, it will fit perfectly in my 650D. LOL. I know you worry about me.

    "A lawyer with his briefcase can steal more than a hundred men with guns."

  18. #16
    Banned

    Status
    Doctor_Death is offline

    Last Online
    25-02-2016 @ 11:04
    Join Date
    Apr 2008
    Location
    Punxsutawney, Pa. - USA
    Posts
    11,789
    CPU: Core i7 3930K
    M/B: ASRock X79 Extreme9
    RAM: 64GBs Kingston Beast 2133MHz
    GPU: Two EVGA GTX 690s in Quad SLI
    • Doctor_Death's Full Spec's
      • Case:
      • Corsair 900D
      • PSU:
      • Corsair AX1200i
      • Cooling:
      • Complete system cooled by EK Water Blocks
      • Sound:
      • Creative Sound Core 3D Audio 7.1
      • Monitor:
      • Dell U3011 30" 2560 x 1600 Res
      • OS:
      • Win 7 Ultimate 64Bit
      • Misc:
      • Asus Blu-Ray, Asus 24X DVD Burner, Max Mechanicalkeyboard / Razer Abyssus Mouse / Razer eXact Mat with wrist rest.
    Thanks
    339
    Thanked 2,582 Times in 1,551 Posts
    Points: 490,204, Level: 100
    Points: 490,204, Level: 100
    Level completed: 0%,
    Points required for next Level: 0
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Overall activity: 0%

    Default Re: My Corsair H100 died

    Quote Originally Posted by Deton View Post
    geezzz...then it's more than one bad apple, perhaps the manufacture decides to cut corner at the last minute to meet the production quota???

    What's Corsair respond on this matter?
    Deton, there's less than 10 people that have had problems, considering the thousands of units that have been sold, that's not very many defective units, and from what I hear Corsair has replaced them right away.

  19. The following user thanks Doctor_Death For this above post:

    4hams (18-09-2011)

Page 1 of 4 1 2 3 4 LastLast

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Corsair Hydro H100 and H80 CPU Coolers
    By Lil' Dead in forum Cooling
    Replies: 32
    Last Post: 20-12-2011, 22:48
  2. Corsair H100 gets Award from the "future"
    By shattered.likeness in forum General Discussion
    Replies: 15
    Last Post: 05-09-2011, 19:49
  3. The Day the Gaming Industry Died
    By Lil' Dead in forum General Gaming
    Replies: 4
    Last Post: 16-06-2010, 12:36
  4. 3870x2 died they gave me 4890
    By Geralt in forum Graphics Cards
    Replies: 17
    Last Post: 18-07-2009, 23:15
  5. I think my CPU died....
    By Benji in forum General Hardware
    Replies: 3
    Last Post: 24-05-2009, 18:07

Search tags for this page

asetek 570lx vs corsair h100

,
asetek 570lx vs h100
,

corsair h100 dead

,

corsair h100 fans not spinning

,
corsair h100 i et zalman z 11
,
corsair h100 led died
,

corsair h100 no led

,

corsair h100 not turning on

,
corsair h100 not turning on first install
,
corsair h100 one fan died
,

corsair h100 problems

,

h100 dead

,
h100 recalls
,
intel core i7 2600k @5.325ghz
Click on a term to search for related topics.

Tags for this Thread