motherboards
Arctic
Arctic Feezer 7x
Results 1 to 12 of 12

Thread: Were to plug in my pump?

  1. #1
    Core Member

    Status
    killjoyjim is offline

    Last Online
    24-08-2018 @ 17:02
    Join Date
    Dec 2011
    Location
    corry pa
    Posts
    4,837
    CPU: INTEL i5 4670k
    M/B: ASUS MAXIMUS VII HERO
    RAM: CORSAIR DOMINATOR PLATINUM 16GB 2133
    GPU: Two GIGABYTE 670. With EXPC waterblocks and back plats.
    • killjoyjim's Full Spec's
      • Case:
      • Case Labs Magnum TH 10. With custom paint.
      • PSU:
      • AZZA TITAN 1000w
      • Cooling:
      • D5 pump with dress up kit and block. Custom Res with three XSPC 480mm rads. Swifteck CPU block and Two XSPC water blocks on my 670 cards.
      • Sound:
      • ASUS ROG THUNDERBOLT
      • Monitor:
      • 47'' samsung tv
      • OS:
      • windows 7
      • Misc:
      • OCZ 60gb fot OS. And a OCZ 240 ssd.
    Thanks
    30
    Thanked 416 Times in 378 Posts
    Points: 75,825, Level: 85
    Points: 75,825, Level: 85
    Level completed: 58%,
    Points required for next Level: 725
    Level completed: 58%, Points required for next Level: 725
    Overall activity: 0%
    Overall activity: 0%

    Default Were to plug in my pump?

    Hi all. I need to know can I plug my waco pump into a fan lead on my Moutherboard? Or dose it need to be pluged in to the CPU fan on moutherboard?

  2. #2
    Regular Member

    Status
    Pete is offline

    Last Online
    15-12-2014 @ 18:04
    Join Date
    May 2013
    Location
    Denmark
    Posts
    359
    CPU: Intel i5 4670K @ 4.4GHz
    M/B: Asus Z87-PRO
    RAM: 2x8Gb Kingston HyperX Beast 2133MHz
    GPU: Gigabyte Nvidia GTX780 @ 1223MHz
    • Pete's Full Spec's
      • Case:
      • Fractal design Arc midi R2
      • PSU:
      • XFX ProSeries Black Edition 850W
      • Cooling:
      • Alphacool VPP655 pump 2x Alphacool UT60 240 rads EK Supremacy Plexi cpu-block EK-FC Titan SE + backplate gpu-block 4x NB-eLoop 1900rpm fans
      • Monitor:
      • BenQ GL2460 24" LED
      • OS:
      • Win 8 Pro N
    Thanks
    9
    Thanked 18 Times in 18 Posts
    Points: 15,478, Level: 37
    Points: 15,478, Level: 37
    Level completed: 79%,
    Points required for next Level: 172
    Level completed: 79%, Points required for next Level: 172
    Overall activity: 28.0%
    Overall activity: 28.0%

    Default Re: Were to plug in my pump?

    dont plug it in to you motherboard, it draws way too much power

  3. #3
    Folding Team Leader

    Status
    grumpydaddy is offline

    Last Online
    23-03-2019 @ 20:29
    Join Date
    Jan 2008
    Location
    UK (Plymouth)
    Posts
    3,167
    CPU: E5-26xx @2.54
    M/B: MSI X79 GD45 8d
    RAM: 16GB (2*8) G-Skill Trident X 2400 10,12,12 @1866
    GPU: sapphire hd7950
    • grumpydaddy's Full Spec's
      • Case:
      • Lian Li PC90B
      • PSU:
      • PC P&C 910
      • Cooling:
      • C4 NIC
      • Sound:
      • with mb
      • Monitor:
      • dell 24inch
      • OS:
      • Win7 Ult
      • Misc:
      • CPU is an ES processor with 8 cores/16 threads
    Thanks
    216
    Thanked 509 Times in 395 Posts
    Points: 51,457, Level: 70
    Points: 51,457, Level: 70
    Level completed: 22%,
    Points required for next Level: 1,093
    Level completed: 22%, Points required for next Level: 1,093
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Were to plug in my pump?

    What pump? That is to say which ddc pump do you have?

    Normally pump connected to molex from psu and rpm sensor to any fan header.

    If you have the 3.2 then I would connect the Molex as usual then the control connector to the cpu fan header if you want to control pump speed via bios/program

    Like Pete said pump will draw 10-18watts which is a shed load more than a fan so don't power it from MB
    Rig2: 2*e5-26xx (16c/32t @2.4), Asus z9 pe-d8 ws, 32gb ripjawsz under water, rig3 2*e5-26xx (16c/32t @2.4), Supermicro 7047A-T 16GB 1600 ecc reg, on air, Rig4: 2*e5-26xx (16c/32t @3.1), Supermicro x9 DAi 16GB 1600 ecc reg, on air, Rig5: 2*e5-2660 (16c/32t @2.7), Supermicro x9 DRW iF 32GB 1600 ecc reg, on air

  4. #4
    Regular Member

    Status
    PoLoMoTo is offline

    Last Online
    01-02-2020 @ 10:51
    Join Date
    Nov 2011
    Location
    US
    Posts
    3,230
    CPU: i7-5960x, 8 cores, 16 threads @ 3.5GHz
    M/B: Asus X99 Deluxe
    RAM: 16GB (4 x 4GB), G.Skill Ripsaws II, DDR4-2666
    GPU: Gigabyte Aorus 2080 Ti Waterblock
    • PoLoMoTo's Full Spec's
      • Case:
      • Coolermaster Cosmos C700m
      • PSU:
      • Corsair H1000i 1000 watt
      • Cooling:
      • 3x120mm rad, 1x120mm rad, 4x Noctua Industrial NFF-12 3000RPM, XSPC Raystorm CPU Block, CALC Photon 270mm D5 res/pump combo
      • Sound:
      • Schiit Modi, Samson SM10, Schiit Valhalla 2
      • Monitor:
      • LG 38WK95C-W 38" 21:9 3840x1600
      • OS:
      • Windows 10 and Arch Linux
      • Misc:
      • OLKB Planck 40% keyboard with Godspeed keycaps and Logitech G930 mouse with PowerPlay wireless charging mousepad
    Thanks
    73
    Thanked 119 Times in 109 Posts
    Points: 21,659, Level: 45
    Points: 21,659, Level: 45
    Level completed: 1%,
    Points required for next Level: 891
    Level completed: 1%, Points required for next Level: 891
    Overall activity: 99.6%
    Overall activity: 99.6%

    Default Re: Were to plug in my pump?

    If its similar to mine it should have molex for power and a fan connector for the mobo to control it although mine doesn't seem to work

  5. #5
    Core Member

    Status
    killjoyjim is offline

    Last Online
    24-08-2018 @ 17:02
    Join Date
    Dec 2011
    Location
    corry pa
    Posts
    4,837
    CPU: INTEL i5 4670k
    M/B: ASUS MAXIMUS VII HERO
    RAM: CORSAIR DOMINATOR PLATINUM 16GB 2133
    GPU: Two GIGABYTE 670. With EXPC waterblocks and back plats.
    • killjoyjim's Full Spec's
      • Case:
      • Case Labs Magnum TH 10. With custom paint.
      • PSU:
      • AZZA TITAN 1000w
      • Cooling:
      • D5 pump with dress up kit and block. Custom Res with three XSPC 480mm rads. Swifteck CPU block and Two XSPC water blocks on my 670 cards.
      • Sound:
      • ASUS ROG THUNDERBOLT
      • Monitor:
      • 47'' samsung tv
      • OS:
      • windows 7
      • Misc:
      • OCZ 60gb fot OS. And a OCZ 240 ssd.
    Thanks
    30
    Thanked 416 Times in 378 Posts
    Points: 75,825, Level: 85
    Points: 75,825, Level: 85
    Level completed: 58%,
    Points required for next Level: 725
    Level completed: 58%, Points required for next Level: 725
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Were to plug in my pump?

    It is a XSPC lAING ddc pump. No molex.

  6. #6
    Folding Team Leader

    Status
    grumpydaddy is offline

    Last Online
    23-03-2019 @ 20:29
    Join Date
    Jan 2008
    Location
    UK (Plymouth)
    Posts
    3,167
    CPU: E5-26xx @2.54
    M/B: MSI X79 GD45 8d
    RAM: 16GB (2*8) G-Skill Trident X 2400 10,12,12 @1866
    GPU: sapphire hd7950
    • grumpydaddy's Full Spec's
      • Case:
      • Lian Li PC90B
      • PSU:
      • PC P&C 910
      • Cooling:
      • C4 NIC
      • Sound:
      • with mb
      • Monitor:
      • dell 24inch
      • OS:
      • Win7 Ult
      • Misc:
      • CPU is an ES processor with 8 cores/16 threads
    Thanks
    216
    Thanked 509 Times in 395 Posts
    Points: 51,457, Level: 70
    Points: 51,457, Level: 70
    Level completed: 22%,
    Points required for next Level: 1,093
    Level completed: 22%, Points required for next Level: 1,093
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Were to plug in my pump?

    If it is one like this then details of what you need are there. If not then we need pics as other than the oddball mentioned the only ones I know have Molex plus fan coonnector
    Rig2: 2*e5-26xx (16c/32t @2.4), Asus z9 pe-d8 ws, 32gb ripjawsz under water, rig3 2*e5-26xx (16c/32t @2.4), Supermicro 7047A-T 16GB 1600 ecc reg, on air, Rig4: 2*e5-26xx (16c/32t @3.1), Supermicro x9 DAi 16GB 1600 ecc reg, on air, Rig5: 2*e5-2660 (16c/32t @2.7), Supermicro x9 DRW iF 32GB 1600 ecc reg, on air

  7. #7
    Moderator

    Status
    Solara2xb is offline

    Last Online
    30-08-2017 @ 03:07
    Join Date
    Apr 2011
    Location
    Alta Loma, CA
    Posts
    5,172
    CPU: Intel i7 5930K / Intel i7 4820K / Intel i7 4790K
    M/B: ASUS X99 R5E / ASUS X79 Sabertooth / ASUS Z97 MVIIF
    RAM: 32GB Kingston DDR4 3000MHz / 32GB Corsair 1866MHz / 16GB HyperX Savage 2400MHz
    GPU: EVGA GTX780 TRI SLI Classy / EVGA GTX 780 SLI / XFX R9 290 (xfire) w XSPC WB
    • Solara2xb's Full Spec's
      • Case:
      • Corsair 750D / Corsair A540 / NZXT P630
      • PSU:
      • EVGA 1000G2 / Corsair AX1200 / Corsair AX1200
      • Cooling:
      • ALL Systems running Custom Water Cooling
      • Monitor:
      • 3x Dell 24" IPS on XFX Triple Stand 5760x1200
      • OS:
      • Windows 7 Ultimate
    Thanks
    1,225
    Thanked 558 Times in 491 Posts
    Points: 221,036, Level: 100
    Points: 221,036, Level: 100
    Level completed: 0%,
    Points required for next Level: 0
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Were to plug in my pump?

    Jim, You have the Liang DDC-1 Pump, which is OEM from Liang, those didn't have the molex, but the power is in 3pin format. (fan Header).
    These are only 10 watt pumps, which isn't allot, but can use the 3pin to Molex adapters that normal come with fans
    Like this:


    or do what I did and I had it plugged into a splitter

    Like this one which also powered my fans.

  8. #8
    Moderator

    Status
    Solara2xb is offline

    Last Online
    30-08-2017 @ 03:07
    Join Date
    Apr 2011
    Location
    Alta Loma, CA
    Posts
    5,172
    CPU: Intel i7 5930K / Intel i7 4820K / Intel i7 4790K
    M/B: ASUS X99 R5E / ASUS X79 Sabertooth / ASUS Z97 MVIIF
    RAM: 32GB Kingston DDR4 3000MHz / 32GB Corsair 1866MHz / 16GB HyperX Savage 2400MHz
    GPU: EVGA GTX780 TRI SLI Classy / EVGA GTX 780 SLI / XFX R9 290 (xfire) w XSPC WB
    • Solara2xb's Full Spec's
      • Case:
      • Corsair 750D / Corsair A540 / NZXT P630
      • PSU:
      • EVGA 1000G2 / Corsair AX1200 / Corsair AX1200
      • Cooling:
      • ALL Systems running Custom Water Cooling
      • Monitor:
      • 3x Dell 24" IPS on XFX Triple Stand 5760x1200
      • OS:
      • Windows 7 Ultimate
    Thanks
    1,225
    Thanked 558 Times in 491 Posts
    Points: 221,036, Level: 100
    Points: 221,036, Level: 100
    Level completed: 0%,
    Points required for next Level: 0
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Were to plug in my pump?

    You also use one of these, which is just as good..

  9. #9
    Core Member

    Status
    killjoyjim is offline

    Last Online
    24-08-2018 @ 17:02
    Join Date
    Dec 2011
    Location
    corry pa
    Posts
    4,837
    CPU: INTEL i5 4670k
    M/B: ASUS MAXIMUS VII HERO
    RAM: CORSAIR DOMINATOR PLATINUM 16GB 2133
    GPU: Two GIGABYTE 670. With EXPC waterblocks and back plats.
    • killjoyjim's Full Spec's
      • Case:
      • Case Labs Magnum TH 10. With custom paint.
      • PSU:
      • AZZA TITAN 1000w
      • Cooling:
      • D5 pump with dress up kit and block. Custom Res with three XSPC 480mm rads. Swifteck CPU block and Two XSPC water blocks on my 670 cards.
      • Sound:
      • ASUS ROG THUNDERBOLT
      • Monitor:
      • 47'' samsung tv
      • OS:
      • windows 7
      • Misc:
      • OCZ 60gb fot OS. And a OCZ 240 ssd.
    Thanks
    30
    Thanked 416 Times in 378 Posts
    Points: 75,825, Level: 85
    Points: 75,825, Level: 85
    Level completed: 58%,
    Points required for next Level: 725
    Level completed: 58%, Points required for next Level: 725
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Were to plug in my pump?

    Thank you Kenny.

  10. #10
    Folding Team Leader

    Status
    grumpydaddy is offline

    Last Online
    23-03-2019 @ 20:29
    Join Date
    Jan 2008
    Location
    UK (Plymouth)
    Posts
    3,167
    CPU: E5-26xx @2.54
    M/B: MSI X79 GD45 8d
    RAM: 16GB (2*8) G-Skill Trident X 2400 10,12,12 @1866
    GPU: sapphire hd7950
    • grumpydaddy's Full Spec's
      • Case:
      • Lian Li PC90B
      • PSU:
      • PC P&C 910
      • Cooling:
      • C4 NIC
      • Sound:
      • with mb
      • Monitor:
      • dell 24inch
      • OS:
      • Win7 Ult
      • Misc:
      • CPU is an ES processor with 8 cores/16 threads
    Thanks
    216
    Thanked 509 Times in 395 Posts
    Points: 51,457, Level: 70
    Points: 51,457, Level: 70
    Level completed: 22%,
    Points required for next Level: 1,093
    Level completed: 22%, Points required for next Level: 1,093
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Were to plug in my pump?

    OK, page 2-43 of the manual RAMPAGE III EXTREME - ROG - ASUS suggests that the maximum current on this board is higher than I expected with each header said to be capable of 24w = 2A

    Whilst I would not want to run at the maximum, your 10w pump should be OK. I would double check that plug and the pinouts are right then connect to the cpu fan header
    Rig2: 2*e5-26xx (16c/32t @2.4), Asus z9 pe-d8 ws, 32gb ripjawsz under water, rig3 2*e5-26xx (16c/32t @2.4), Supermicro 7047A-T 16GB 1600 ecc reg, on air, Rig4: 2*e5-26xx (16c/32t @3.1), Supermicro x9 DAi 16GB 1600 ecc reg, on air, Rig5: 2*e5-2660 (16c/32t @2.7), Supermicro x9 DRW iF 32GB 1600 ecc reg, on air

  11. #11
    Moderator

    Status
    Solara2xb is offline

    Last Online
    30-08-2017 @ 03:07
    Join Date
    Apr 2011
    Location
    Alta Loma, CA
    Posts
    5,172
    CPU: Intel i7 5930K / Intel i7 4820K / Intel i7 4790K
    M/B: ASUS X99 R5E / ASUS X79 Sabertooth / ASUS Z97 MVIIF
    RAM: 32GB Kingston DDR4 3000MHz / 32GB Corsair 1866MHz / 16GB HyperX Savage 2400MHz
    GPU: EVGA GTX780 TRI SLI Classy / EVGA GTX 780 SLI / XFX R9 290 (xfire) w XSPC WB
    • Solara2xb's Full Spec's
      • Case:
      • Corsair 750D / Corsair A540 / NZXT P630
      • PSU:
      • EVGA 1000G2 / Corsair AX1200 / Corsair AX1200
      • Cooling:
      • ALL Systems running Custom Water Cooling
      • Monitor:
      • 3x Dell 24" IPS on XFX Triple Stand 5760x1200
      • OS:
      • Windows 7 Ultimate
    Thanks
    1,225
    Thanked 558 Times in 491 Posts
    Points: 221,036, Level: 100
    Points: 221,036, Level: 100
    Level completed: 0%,
    Points required for next Level: 0
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Were to plug in my pump?

    Your board should be able to handle it.. I have the same pump on my test bench and I use the CPU fan header to run the pump.
    10watts is not allot of power, but if you do want to be safe, run it on a molex to 3pin adapter..

  12. #12
    Core Member

    Status
    killjoyjim is offline

    Last Online
    24-08-2018 @ 17:02
    Join Date
    Dec 2011
    Location
    corry pa
    Posts
    4,837
    CPU: INTEL i5 4670k
    M/B: ASUS MAXIMUS VII HERO
    RAM: CORSAIR DOMINATOR PLATINUM 16GB 2133
    GPU: Two GIGABYTE 670. With EXPC waterblocks and back plats.
    • killjoyjim's Full Spec's
      • Case:
      • Case Labs Magnum TH 10. With custom paint.
      • PSU:
      • AZZA TITAN 1000w
      • Cooling:
      • D5 pump with dress up kit and block. Custom Res with three XSPC 480mm rads. Swifteck CPU block and Two XSPC water blocks on my 670 cards.
      • Sound:
      • ASUS ROG THUNDERBOLT
      • Monitor:
      • 47'' samsung tv
      • OS:
      • windows 7
      • Misc:
      • OCZ 60gb fot OS. And a OCZ 240 ssd.
    Thanks
    30
    Thanked 416 Times in 378 Posts
    Points: 75,825, Level: 85
    Points: 75,825, Level: 85
    Level completed: 58%,
    Points required for next Level: 725
    Level completed: 58%, Points required for next Level: 725
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Were to plug in my pump?

    OK. That is were I had it.

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Asus EZ Plug on Crosshair V Formula-Z
    By joshjaks in forum AMD
    Replies: 0
    Last Post: 08-06-2013, 11:37
  2. How do I add a drain tube/plug to my loop
    By SamCR3 in forum Cooling
    Replies: 18
    Last Post: 09-01-2013, 06:11
  3. Replies: 0
    Last Post: 04-05-2011, 14:21
  4. ZoneAlarm release Force Field plug-in
    By News Team in forum Hardware News
    Replies: 0
    Last Post: 23-05-2008, 08:12
  5. windows plug but no play
    By say what in forum Operating Systems
    Replies: 0
    Last Post: 24-11-2006, 10:34

Search tags for this page

asus x99 cooler pump connect
,
can i coinect water cooler pump with molex
,

connect pump to molex or motherboard

,
connect pump to motherboard
,

cooler pump connection

,
hook liquid cooler pump to molex plug
,
how to connect water cooling pump
,

how to connect water pump to mobo

,

how to hook up a liquid cooler to a cpu and how to plug the cpu fan and the pump

,

how to plug in water cooler into mobo

,
how to plug wter cooling m599fx
,

molex fan connector

,

water cooling pump connection

,
where connect pump water cooling
Click on a term to search for related topics.

Tags for this Thread