motherboards
+ Reply to Thread
Results 1 to 12 of 12

Thread: dead GTX570?

  1. #1
    New Member

    Status
    THX-UltraII is offline

    Last Online
    11-10-2012 @ 15:31
    Join Date
    Nov 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Points: 736, Level: 6
    Points: 736, Level: 6
    Level completed: 93%,
    Points required for next Level: 14
    Level completed: 93%, Points required for next Level: 14
    Overall activity: 0%
    Overall activity: 0%

    Default dead GTX570?

    I just got a P N Y GTX570. I plugged the two PCI-e connectors (6-pins) in my 1000watt power supply. I get nothing, zero. Tried to plugin the card in the pci-e slot back a few times to make sure it s tightned but that s also not the problem. Also did a W7 reinstall to be sure but this also gave no result (NVIDIA installation cannot run because no compatible hardware is found). Plugging my monitor with a DVI->mon dongle also gives me a blanc screen......
    Is it a dead GTX570?
    Have to mention that I removed the stickers on the print plate of the card with a knife so maybe I f@#$@# up the card by doing this?
    mb is a ASrock H61M-ITX

  2. #2
    Regular Member

    Status
    PoLoMoTo is offline

    Last Online
    22-03-2014 @ 20:43
    Join Date
    Nov 2011
    Location
    US
    Posts
    3,229
    CPU: i7-980, 6 cores, 12 threads, 4.5 GHz
    M/B: Asus P6X58-E Pro
    RAM: 24GB (6 x 4GB), G.Skill Ripsaw, DDR3-1600, 1730 MHz
    GPU: Reference R9 290x, 1125MHz Core and 1500MHz Memory
    • PoLoMoTo's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • Thortech Thunderbolt 1kW Plus, One 83 amp +12v rail
      • Cooling:
      • 8x 120mm, 4x 140mm, 4 GPU fans, 120.3 Rad Push/Pull
      • Sound:
      • Asus Xonar Essence STX
      • Monitor:
      • ViewSonic V3D231, 23", 1080p & HP x20LED, 20", 1600x900
      • OS:
      • Windows 8 Pro WMC x64
      • Misc:
      • LG Blueray Read-Write Optical drive with LightScribe
    Thanks
    72
    Thanked 119 Times in 109 Posts
    Points: 11,694, Level: 32
    Points: 11,694, Level: 32
    Level completed: 64%,
    Points required for next Level: 256
    Level completed: 64%, Points required for next Level: 256
    Overall activity: 17.0%
    Overall activity: 17.0%

    Default Re: dead GTX570?

    Try disabling the onboard video.

  3. #3
    New Member

    Status
    THX-UltraII is offline

    Last Online
    11-10-2012 @ 15:31
    Join Date
    Nov 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Points: 736, Level: 6
    Points: 736, Level: 6
    Level completed: 93%,
    Points required for next Level: 14
    Level completed: 93%, Points required for next Level: 14
    Overall activity: 0%
    Overall activity: 0%

    Default Re: dead GTX570?

    did that but doesn t work

  4. #4
    Regular Member

    Status
    PoLoMoTo is offline

    Last Online
    22-03-2014 @ 20:43
    Join Date
    Nov 2011
    Location
    US
    Posts
    3,229
    CPU: i7-980, 6 cores, 12 threads, 4.5 GHz
    M/B: Asus P6X58-E Pro
    RAM: 24GB (6 x 4GB), G.Skill Ripsaw, DDR3-1600, 1730 MHz
    GPU: Reference R9 290x, 1125MHz Core and 1500MHz Memory
    • PoLoMoTo's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • Thortech Thunderbolt 1kW Plus, One 83 amp +12v rail
      • Cooling:
      • 8x 120mm, 4x 140mm, 4 GPU fans, 120.3 Rad Push/Pull
      • Sound:
      • Asus Xonar Essence STX
      • Monitor:
      • ViewSonic V3D231, 23", 1080p & HP x20LED, 20", 1600x900
      • OS:
      • Windows 8 Pro WMC x64
      • Misc:
      • LG Blueray Read-Write Optical drive with LightScribe
    Thanks
    72
    Thanked 119 Times in 109 Posts
    Points: 11,694, Level: 32
    Points: 11,694, Level: 32
    Level completed: 64%,
    Points required for next Level: 256
    Level completed: 64%, Points required for next Level: 256
    Overall activity: 17.0%
    Overall activity: 17.0%

    Default Re: dead GTX570?

    Quote Originally Posted by THX-UltraII View Post
    did that but doesn t work
    Make sure your PSU is working, if available try a known good PSU.

  5. #5
    Moderator

    Status
    Solara2xb is offline

    Last Online
    Today @ 06:05
    Join Date
    Apr 2011
    Location
    Alta Loma, CA
    Posts
    4,878
    CPU: Intel i7 5930K / Intel i7 4820K / Intel i7 4770K
    M/B: ASUS X99 R5E / ASUS X79 Sabertooth / ASUS Z97 MVIIF
    RAM: 32GB Kingston DDR4 2400MHz / 32GB Corsair 1866MHz / 16GB Kingston HyperX 1866MHz
    GPU: EVGA GTX780 SLI Classy / EVGA GTX 780 SLI / XFX R9 290 (xfire) w XSPC WB
    • Solara2xb's Full Spec's
      • Case:
      • Corsair 750D / Corsair A540 / NZXT P630
      • PSU:
      • EVGA 1000G2 / Corsair AX1200 / Corsair AX1200
      • Cooling:
      • ALL Systems running Custom Water Cooling
      • Monitor:
      • 3x Dell 24" IPS on XFX Triple Stand 5760x1200
      • OS:
      • Windows 7 Ultimate
    Thanks
    1,144
    Thanked 520 Times in 453 Posts
    Points: 97,937, Level: 97
    Points: 97,937, Level: 97
    Level completed: 45%,
    Points required for next Level: 1,113
    Level completed: 45%, Points required for next Level: 1,113
    Overall activity: 99.5%
    Overall activity: 99.5%

    Default Re: dead GTX570?

    Quote Originally Posted by PoLoMoTo View Post
    Make sure your PSU is working, if available try a known good PSU.
    Try this and let us know..

  6. #6
    Banned

    Status
    Drdeath is offline

    Last Online
    02-07-2013 @ 02:04
    Join Date
    May 2010
    Location
    Chicago Burbs
    Posts
    8,556
    CPU: Intel Core i7 3930K @ 5GHz
    M/B: ASROCK X79 Extreme 6
    RAM: 16G G.Skill Trident 2400MHz
    GPU: 2 x Radeon 2G 7970 Liquid cooled
    • Drdeath's Full Spec's
      • Case:
      • Phobya CooliT TestBennch
      • PSU:
      • Nexus 1100W
      • Cooling:
      • Custom water. Apogee XT Rev 1, Thermachill TA120.3 plus 120.2, Swiftec Micro res, MCP655
      • Sound:
      • OB
      • Monitor:
      • Viewsonic 27"
      • OS:
      • Win7 64bit
    Thanks
    275
    Thanked 1,022 Times in 880 Posts
    Points: 28,339, Level: 51
    Points: 28,339, Level: 51
    Level completed: 72%,
    Points required for next Level: 311
    Level completed: 72%, Points required for next Level: 311
    Overall activity: 99.9%
    Overall activity: 99.9%

    Default Re: dead GTX570?

    Try a different PCIE slot

  7. #7
    Core Member

    Status
    Irocing is offline

    Last Online
    19-08-2012 @ 23:32
    Join Date
    Oct 2011
    Location
    Arizona (Area 52)
    Posts
    1,755
    CPU: i7 930 Lapped 4.51@1.42 HT ON
    M/B: Asus P6X58D-E
    RAM: Corsair Dominator 6gig 3x2 1600@1723
    GPU: Sapphire 7970 OC Edition 1275/1700/1.200V
    • Irocing's Full Spec's
      • Case:
      • CM 690 II Advanced (Swiss cheezed)
      • PSU:
      • Coolmaster 850 82A Modular
      • Cooling:
      • EK-XT Micro-Rez XSPC 240 X 2 + XSPC 120 MCP 355 pump-600.5
      • Sound:
      • CL SB Titanium/ Bose 2.1
      • Monitor:
      • Samsung 26- 1920x1200
      • OS:
      • Win 7 SP1 HE 64bit
      • Misc:
      • Lamptron FC-2 Lamptron 5 Pole-5v-12v 9- Hi Speed Scythes thru controller Keyboard Logiteck G-15 M4 128g Boot WD 640 Sata III Storage
    Thanks
    29
    Thanked 139 Times in 124 Posts
    Points: 5,047, Level: 20
    Points: 5,047, Level: 20
    Level completed: 99%,
    Points required for next Level: 3
    Level completed: 99%, Points required for next Level: 3
    Overall activity: 25.0%
    Overall activity: 25.0%

    Default Re: dead GTX570?

    Have you got a multimeter?
    Test the rails instead of changing out the PS.
    Although loaded draw sometimes brings out a flaw.

    later

  8. #8
    Regular Member

    Status
    PoLoMoTo is offline

    Last Online
    22-03-2014 @ 20:43
    Join Date
    Nov 2011
    Location
    US
    Posts
    3,229
    CPU: i7-980, 6 cores, 12 threads, 4.5 GHz
    M/B: Asus P6X58-E Pro
    RAM: 24GB (6 x 4GB), G.Skill Ripsaw, DDR3-1600, 1730 MHz
    GPU: Reference R9 290x, 1125MHz Core and 1500MHz Memory
    • PoLoMoTo's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • Thortech Thunderbolt 1kW Plus, One 83 amp +12v rail
      • Cooling:
      • 8x 120mm, 4x 140mm, 4 GPU fans, 120.3 Rad Push/Pull
      • Sound:
      • Asus Xonar Essence STX
      • Monitor:
      • ViewSonic V3D231, 23", 1080p & HP x20LED, 20", 1600x900
      • OS:
      • Windows 8 Pro WMC x64
      • Misc:
      • LG Blueray Read-Write Optical drive with LightScribe
    Thanks
    72
    Thanked 119 Times in 109 Posts
    Points: 11,694, Level: 32
    Points: 11,694, Level: 32
    Level completed: 64%,
    Points required for next Level: 256
    Level completed: 64%, Points required for next Level: 256
    Overall activity: 17.0%
    Overall activity: 17.0%

    Default Re: dead GTX570?

    Quote Originally Posted by Drdeath View Post
    Try a different PCIE slot
    ITX boards are lucky to have 1....

  9. #9
    Core Member

    Status
    killjoyjim is offline

    Last Online
    Yesterday @ 16:41
    Join Date
    Dec 2011
    Location
    corry pa
    Posts
    4,219
    CPU: INTEL i5 4670k
    M/B: ECS l337 gaming,gank,z87h3-a2x z87 chip set
    RAM: CORSAIR DOMINATOR PLATINUM 16GB 2133
    GPU: asus580 directcuII 1536 MB GDDR5 / 782HZ OVERCLOCK
    • killjoyjim's Full Spec's
      • Case:
      • Corsair 700d With custume pait Black Cherry with perial.
      • PSU:
      • AZZA TITAN 1000w
      • Cooling:
      • Laing DDC Pump. with XSPC CLEAR TOP,XSPC block for cpu, Koolance 4x120mm copper Vert rad in top,Black Ice 120mm in the front,Danger Den Dual bay res ,Primochill PRO-LRT Tubing.
      • Sound:
      • ASUS ROG THUNDERBOLT
      • Monitor:
      • 47'' samsung tv
      • OS:
      • windows 7
      • Misc:
      • OCZ 60gb fot OS. And a OCZ 240 ssd.
    Thanks
    30
    Thanked 344 Times in 311 Posts
    Points: 26,074, Level: 49
    Points: 26,074, Level: 49
    Level completed: 53%,
    Points required for next Level: 476
    Level completed: 53%, Points required for next Level: 476
    Overall activity: 99.4%
    Overall activity: 99.4%

    Default Re: dead GTX570?

    put a jumper wire on the grean & black wire on the psu.IF bad It wont start up.

  10. #10
    Regular Member

    Status
    PoLoMoTo is offline

    Last Online
    22-03-2014 @ 20:43
    Join Date
    Nov 2011
    Location
    US
    Posts
    3,229
    CPU: i7-980, 6 cores, 12 threads, 4.5 GHz
    M/B: Asus P6X58-E Pro
    RAM: 24GB (6 x 4GB), G.Skill Ripsaw, DDR3-1600, 1730 MHz
    GPU: Reference R9 290x, 1125MHz Core and 1500MHz Memory
    • PoLoMoTo's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • Thortech Thunderbolt 1kW Plus, One 83 amp +12v rail
      • Cooling:
      • 8x 120mm, 4x 140mm, 4 GPU fans, 120.3 Rad Push/Pull
      • Sound:
      • Asus Xonar Essence STX
      • Monitor:
      • ViewSonic V3D231, 23", 1080p & HP x20LED, 20", 1600x900
      • OS:
      • Windows 8 Pro WMC x64
      • Misc:
      • LG Blueray Read-Write Optical drive with LightScribe
    Thanks
    72
    Thanked 119 Times in 109 Posts
    Points: 11,694, Level: 32
    Points: 11,694, Level: 32
    Level completed: 64%,
    Points required for next Level: 256
    Level completed: 64%, Points required for next Level: 256
    Overall activity: 17.0%
    Overall activity: 17.0%

    Default Re: dead GTX570?

    Quote Originally Posted by killjoyjim View Post
    put a jumper wire on the grean & black wire on the psu.IF bad It wont start up.
    Well the computer hes says does start but the graphics card never works he need to check the PCI-e plugs to make sure they are getting the correct voltage.

  11. #11
    Core Member

    Status
    realneil is offline

    Last Online
    Yesterday @ 20:27
    Join Date
    Sep 2011
    Location
    Virginia, USA
    Posts
    7,503
    CPU: i7-2600K and FX-8350
    M/B: ASRock Z68 Extreme 7 Gen-3 and 990FX Extreme3
    RAM: 16GB Mushkin Redline 2133 & 16GB GSKill Red 2133
    GPU: 2X-R9-280Xs Crossfire & 2X-GTX-570s SLI
    • realneil's Full Spec's
      • Case:
      • Rosewill Blackhawk Ultra & Rosewill Blackhawk
      • PSU:
      • SeaSonic & Rosewill
      • Cooling:
      • Corsair H80 and Corsair H60, Both with dual high flow, low noise fans added.
      • Sound:
      • both onboard
      • Monitor:
      • ASUS 27" & Hannspree 24"
      • OS:
      • Win-7 64Bit on both
      • Misc:
      • JBL Creature-II Sound systems on each PC, Plextor DVD Burners on both systems. Third System: AMD FX-8350 on an ASRock Mainboard 16GB GSKill Sniper DDR3-1600 with 2 GTX-570s in SLI Two 120GB SSDs and one 1.5TB HDD Plextor DVD Burner ViewSonic 23" Screen
    Thanks
    1,348
    Thanked 773 Times in 682 Posts
    Points: 30,713, Level: 53
    Points: 30,713, Level: 53
    Level completed: 88%,
    Points required for next Level: 137
    Level completed: 88%, Points required for next Level: 137
    Overall activity: 99.8%
    Overall activity: 99.8%

    Default Re: dead GTX570?

    Quote Originally Posted by THX-UltraII View Post
    Have to mention that I removed the stickers on the print plate of the card with a knife so maybe I f@#$@# up the card by doing this?

    Was the card plugged into the motherboard's PCI-E slot at the time?

    Were the two power plugs connected? I assume that power would have been off, but sometimes there is residual power present in the system for a few minutes after shutdown.

    Why did you remove those stickers? (I guess it doesn't matter)

    Would like to help you further, but we need you to go to your user control panel and fill in your system's specs for us. This helps us in diagnosing problems when you have them and ask for help.
    Welcome to our site too,.......

  12. #12
    Core Member

    Status
    killjoyjim is offline

    Last Online
    Yesterday @ 16:41
    Join Date
    Dec 2011
    Location
    corry pa
    Posts
    4,219
    CPU: INTEL i5 4670k
    M/B: ECS l337 gaming,gank,z87h3-a2x z87 chip set
    RAM: CORSAIR DOMINATOR PLATINUM 16GB 2133
    GPU: asus580 directcuII 1536 MB GDDR5 / 782HZ OVERCLOCK
    • killjoyjim's Full Spec's
      • Case:
      • Corsair 700d With custume pait Black Cherry with perial.
      • PSU:
      • AZZA TITAN 1000w
      • Cooling:
      • Laing DDC Pump. with XSPC CLEAR TOP,XSPC block for cpu, Koolance 4x120mm copper Vert rad in top,Black Ice 120mm in the front,Danger Den Dual bay res ,Primochill PRO-LRT Tubing.
      • Sound:
      • ASUS ROG THUNDERBOLT
      • Monitor:
      • 47'' samsung tv
      • OS:
      • windows 7
      • Misc:
      • OCZ 60gb fot OS. And a OCZ 240 ssd.
    Thanks
    30
    Thanked 344 Times in 311 Posts
    Points: 26,074, Level: 49
    Points: 26,074, Level: 49
    Level completed: 53%,
    Points required for next Level: 476
    Level completed: 53%, Points required for next Level: 476
    Overall activity: 99.4%
    Overall activity: 99.4%

    Default Re: dead GTX570?

    Yes welcome tp pure.

+ Reply to Thread

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. M14x dead
    By KEEVS in forum Laptops & Mobile Computing
    Replies: 38
    Last Post: 07-03-2012, 14:54
  2. SOPA is dead
    By Lil' Dead in forum General Discussion
    Replies: 3
    Last Post: 22-01-2012, 09:38
  3. ASUS GTX570 Direct Cu II arrived...!!!
    By maestrobg in forum Video Card Overclocking
    Replies: 2
    Last Post: 04-06-2011, 21:07
  4. almost dead HD
    By Mooseman in forum Drives & Storage
    Replies: 11
    Last Post: 19-10-2009, 10:30
  5. Dead motherboard
    By Ciro in forum Intel
    Replies: 8
    Last Post: 17-03-2007, 21:04

Search tags for this page

gtx 570 asrock 870 extreme sata connector blocks video card

Click on a term to search for related topics.

Tags for this Thread