motherboards
Arctic
Arctic Feezer 7x
Results 1 to 3 of 3

Thread: Powercolor has GREAT service...

  1. #1
    Regular Member

    Status
    criss_glitch666 is offline

    Last Online
    09-03-2015 @ 23:28
    Join Date
    Dec 2008
    Posts
    1,777
    Thanks
    275
    Thanked 112 Times in 95 Posts
    Points: 13,054, Level: 34
    Points: 13,054, Level: 34
    Level completed: 58%,
    Points required for next Level: 296
    Level completed: 58%, Points required for next Level: 296
    Overall activity: 14.0%
    Overall activity: 14.0%

    Default Powercolor has GREAT service...

    I had been having a bit of artifacting and what not recently while running my cards at stock clocks. Yesterday I had decided to open up Afterburner and Kombustor to see my temps under load. Card 1 (Sapphire) didn't go above 65C, but card 2 (Powercolor, replacement) was hitting 120C!!!!! This being after running Kombustor for about 5 seconds. Today (just now) I decided to take the card out and see if it was clogged or something. When I took the heatsink off I pretty much sh*t myself! I have no camera at the moment so I could not take a picture. The entire GPU was COVERED in thermal compound. I mean covered and oozing over the top and onto the PCB. It was disgusting to see what Powercolor did for my replacement card. Has anyone else had this happen to them? I am glad I checked it out or else I would have burnt my card!

  2. #2
    Moderator

    Status
    Solara2xb is offline

    Last Online
    30-08-2017 @ 03:07
    Join Date
    Apr 2011
    Location
    Alta Loma, CA
    Posts
    5,172
    CPU: Intel i7 5930K / Intel i7 4820K / Intel i7 4790K
    M/B: ASUS X99 R5E / ASUS X79 Sabertooth / ASUS Z97 MVIIF
    RAM: 32GB Kingston DDR4 3000MHz / 32GB Corsair 1866MHz / 16GB HyperX Savage 2400MHz
    GPU: EVGA GTX780 TRI SLI Classy / EVGA GTX 780 SLI / XFX R9 290 (xfire) w XSPC WB
    • Solara2xb's Full Spec's
      • Case:
      • Corsair 750D / Corsair A540 / NZXT P630
      • PSU:
      • EVGA 1000G2 / Corsair AX1200 / Corsair AX1200
      • Cooling:
      • ALL Systems running Custom Water Cooling
      • Monitor:
      • 3x Dell 24" IPS on XFX Triple Stand 5760x1200
      • OS:
      • Windows 7 Ultimate
    Thanks
    1,225
    Thanked 558 Times in 491 Posts
    Points: 221,036, Level: 100
    Points: 221,036, Level: 100
    Level completed: 0%,
    Points required for next Level: 0
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Powercolor has GREAT service...

    Never had this issue before, I have never used powercolor before..
    I stick to mostly: XFX, Sapphire and Evga

  3. #3
    Core Member

    Status
    SamCR3 is offline

    Last Online
    21-06-2020 @ 14:04
    Join Date
    Jul 2011
    Location
    Seattle, Washington USA
    Posts
    4,222
    CPU: AMD FX-8350 @ 4.6Ghz
    M/B: Asus Crosshair V Formula
    RAM: 16GB Corsair Dominator GT 1866MHz (9-10-9-27)
    GPU: XFX HD 7970 Black Edition 3GB and Diamond HD 7970 3GB both @ 1125/1575MHz
    • SamCR3's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • OCZ Fatal1ty 1000 Watt
      • Cooling:
      • XSPC RayStorm CPU Block, XSPC X20 750 Pump/Res, CoolIt 360MM Rad. w/6 x Noctua NF-F12 PWM Fans (Push/Pull) and PrimoFlex Pro LRT UV Red Tubing; 5 x 140 MM Bitfenx Spectre Pro Red LED Fans on NZXT Sentry Mix Fan Controller
      • Sound:
      • SupremeFX X-Fi 2
      • Monitor:
      • 1 x Samsung SyncMaster SA350H 27 in.
      • OS:
      • Windows 7 Home Premium 64-bit
      • Misc:
      • CM Storm Trigger Mechanical Keyboard; CM Storm Sentinel Zero-G Gaming Mouse; Logitech z523 2.1 Speaker System; Logitech 600 Desktop Microphone
    Thanks
    867
    Thanked 430 Times in 386 Posts
    Points: 26,844, Level: 50
    Points: 26,844, Level: 50
    Level completed: 30%,
    Points required for next Level: 706
    Level completed: 30%, Points required for next Level: 706
    Overall activity: 0%
    Overall activity: 0%

    Default Re: Powercolor has GREAT service...

    Never had a powercolor; Just XFX and Sapphire. Had excellent luck with both and service is great with XFX. The whole RMA process on my 7970 BE only took two weeks from start to finish, including the time sent the first email to the time I got the card back.
    2nd Rig: AMD FX-8120; Corsair H105 ; Gigabyte 990FXA-UD3; 16GB G.Skill Ripjaws X Series 1600MHz; 2 x PowerColor HD 7870 Myst. Ed. (Tahiti LE); Fractal Design Arc XL; SeaSonic X Series 850W
    3rd Rig: AMD A6-3650; Asetek 550LC; Asus F1A75-M Pro; 8GB Kingston HyperX; XFX HD 6670 1GB GDDR5; Antec 300; Thermaltake TR2 650W

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. ECS Takes its 99-Hour Replacement Service Even Further
    By News Team in forum Hardware News
    Replies: 1
    Last Post: 15-06-2012, 10:13
  2. XSPC Customer Service Issue's
    By TDotts25 in forum Cooling
    Replies: 18
    Last Post: 03-02-2011, 15:15
  3. Replies: 0
    Last Post: 18-10-2010, 19:31
  4. Visiontek service
    By Drdeath in forum General Discussion
    Replies: 0
    Last Post: 25-06-2010, 16:20
  5. First Vista service pack getting better and BETA in Q1
    By News Team in forum Hardware News
    Replies: 1
    Last Post: 30-08-2007, 20:32

Search tags for this page

hackintosh artifacting amd 6670
,

powercolor rma

Click on a term to search for related topics.

Tags for this Thread