motherboards
Arctic
Page 1 of 2 1 2 LastLast
Results 1 to 16 of 19

Thread: New GPU, Black screen after update. Help

  1. #1
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default New GPU, Black screen after update. Help

    i decided to update my old 7850's to some new 7970's

    I...
    1) uninstalled old drivers
    2) took cards out
    3) put new cards in
    4) put hdmi cable in TOP 7970
    5) downloaded and installed new drivers
    6) rebooted pc and i got the windows loading screen, then when booting to destop the screen goes black and just sits there. I can hear the sound of windows booting.

    I moved the HDMI cable down to the SECOND 7970 just to see, and bam it works.... why can i not get signal from my first card? or can i just leave it how it is now and be fine?

  2. #2
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    update** the fans actually stop spinning on the first card when windows boots, which leads me to believe that the card just shuts off? idk whats going on with it

  3. #3
    Moderator

    Status
    Solara2xb is offline

    Last Online
    30-08-2017 @ 03:07
    Join Date
    Apr 2011
    Location
    Alta Loma, CA
    Posts
    5,172
    CPU: Intel i7 5930K / Intel i7 4820K / Intel i7 4790K
    M/B: ASUS X99 R5E / ASUS X79 Sabertooth / ASUS Z97 MVIIF
    RAM: 32GB Kingston DDR4 3000MHz / 32GB Corsair 1866MHz / 16GB HyperX Savage 2400MHz
    GPU: EVGA GTX780 TRI SLI Classy / EVGA GTX 780 SLI / XFX R9 290 (xfire) w XSPC WB
    • Solara2xb's Full Spec's
      • Case:
      • Corsair 750D / Corsair A540 / NZXT P630
      • PSU:
      • EVGA 1000G2 / Corsair AX1200 / Corsair AX1200
      • Cooling:
      • ALL Systems running Custom Water Cooling
      • Monitor:
      • 3x Dell 24" IPS on XFX Triple Stand 5760x1200
      • OS:
      • Windows 7 Ultimate
    Thanks
    1,225
    Thanked 558 Times in 491 Posts
    Points: 221,036, Level: 100
    Points: 221,036, Level: 100
    Level completed: 0%,
    Points required for next Level: 0
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    Sounds like the top card is not working like it should.

    Maybe check each card on its own and see if it does that also..

  4. #4
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    Quote Originally Posted by Solara2xb View Post
    Sounds like the top card is not working like it should.

    Maybe check each card on its own and see if it does that also..
    just tried that now, and it is working perfect with 1 card! going to try installing the second now and i will see what happens

  5. #5
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    with one card in, the computer works perfect, put the second card in, and i now got it to boot into windows like everything is fine. but as soon as you try to load up a game or something. It freezes and i get a message that the display driver stopped working, and then the computer Freezes. Im thinking its just my PSU

  6. #6
    Moderator

    Status
    Solara2xb is offline

    Last Online
    30-08-2017 @ 03:07
    Join Date
    Apr 2011
    Location
    Alta Loma, CA
    Posts
    5,172
    CPU: Intel i7 5930K / Intel i7 4820K / Intel i7 4790K
    M/B: ASUS X99 R5E / ASUS X79 Sabertooth / ASUS Z97 MVIIF
    RAM: 32GB Kingston DDR4 3000MHz / 32GB Corsair 1866MHz / 16GB HyperX Savage 2400MHz
    GPU: EVGA GTX780 TRI SLI Classy / EVGA GTX 780 SLI / XFX R9 290 (xfire) w XSPC WB
    • Solara2xb's Full Spec's
      • Case:
      • Corsair 750D / Corsair A540 / NZXT P630
      • PSU:
      • EVGA 1000G2 / Corsair AX1200 / Corsair AX1200
      • Cooling:
      • ALL Systems running Custom Water Cooling
      • Monitor:
      • 3x Dell 24" IPS on XFX Triple Stand 5760x1200
      • OS:
      • Windows 7 Ultimate
    Thanks
    1,225
    Thanked 558 Times in 491 Posts
    Points: 221,036, Level: 100
    Points: 221,036, Level: 100
    Level completed: 0%,
    Points required for next Level: 0
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    what kind of PSU and what are the amps on the 12v rail.
    It can be, but if your profile is correct you are running a 850watt PSU. Which is normally more than enough power.

  7. #7
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    Quote Originally Posted by Solara2xb View Post
    what kind of PSU and what are the amps on the 12v rail.
    It can be, but if your profile is correct you are running a 850watt PSU. Which is normally more than enough power.
    profile is correct, im running a cheapo kentek 850 watt PSU, which im starting to think is the problem for this. i only have 1 8 pin and 1 6 pin off the PSU, so i bought some molex to 8 pin and molex to 6 pin adapters which again.....is most likely my problem

  8. #8
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    tried all cards individually again, and this time one of the cards wouldnt post a signal.... if you turn the pc on 5 times, 1-2 times the card works, now im thinking that i have a faulty card

  9. #9
    Core Member

    Status
    killjoyjim is offline

    Last Online
    24-08-2018 @ 17:02
    Join Date
    Dec 2011
    Location
    corry pa
    Posts
    4,837
    CPU: INTEL i5 4670k
    M/B: ASUS MAXIMUS VII HERO
    RAM: CORSAIR DOMINATOR PLATINUM 16GB 2133
    GPU: Two GIGABYTE 670. With EXPC waterblocks and back plats.
    • killjoyjim's Full Spec's
      • Case:
      • Case Labs Magnum TH 10. With custom paint.
      • PSU:
      • AZZA TITAN 1000w
      • Cooling:
      • D5 pump with dress up kit and block. Custom Res with three XSPC 480mm rads. Swifteck CPU block and Two XSPC water blocks on my 670 cards.
      • Sound:
      • ASUS ROG THUNDERBOLT
      • Monitor:
      • 47'' samsung tv
      • OS:
      • windows 7
      • Misc:
      • OCZ 60gb fot OS. And a OCZ 240 ssd.
    Thanks
    30
    Thanked 416 Times in 378 Posts
    Points: 75,825, Level: 85
    Points: 75,825, Level: 85
    Level completed: 58%,
    Points required for next Level: 725
    Level completed: 58%, Points required for next Level: 725
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    Can ya do a RMA on the card?

  10. #10
    Moderator

    Status
    Cyberburnout is offline

    Last Online
    20-10-2017 @ 11:01
    Join Date
    Jul 2012
    Location
    GROVE CITY OHIO
    Posts
    5,362
    CPU: Intel i7-5820k
    M/B: ASRock X99 WS
    RAM: 32GB Crucial DDR4 2133
    GPU: 2 R9-290s Xfire
    • Cyberburnout's Full Spec's
      • Case:
      • Urban T81
      • PSU:
      • CM Silent 350w
      • Cooling:
      • Custom H20, Ek blocks for CPU and GPUs
      • Sound:
      • ONBOARD
      • Monitor:
      • Dual 24"
      • OS:
      • WINDOWS 7 ULTIMATE X64
      • Misc:
      • White LED lighting
    Thanks
    61
    Thanked 1,166 Times in 663 Posts
    Points: 26,323, Level: 49
    Points: 26,323, Level: 49
    Level completed: 78%,
    Points required for next Level: 227
    Level completed: 78%, Points required for next Level: 227
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    At first it was sounding like what I was dealing with a few weeks ago. Mine was the PCIe slot taking a dump. Board needed to be replaced. As i continued to read the more it started to sounds like one of your GPUs is shot. Hope you can RMA it without a bunch of hassle. What Brand is it?
    "If you got it, Build it"

    A+ Certified. Dell, Lenovo, HP, Lexmarks, Xerox, Panasonic and NEC Certified ASP.

  11. #11
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    XFX, then non black edition...it's not the motherboard because like I said my crossfore 7850's worked perfect, I believe it is the card. Just strange the card works in safe mode, and before driver update... I have never seen this before. I bought them off a guy on eBay who swears they worked but is willing to take them back if I ship them to him

  12. #12
    Core Member

    Status
    Ciarlatano is offline

    Last Online
    08-09-2017 @ 13:12
    Join Date
    Dec 2011
    Location
    NYC Metro Area
    Posts
    816
    CPU: Intel 4790K @ 4.6GHz
    M/B: ASUS Z97 Sabertooth
    RAM: 16GB Patriot Viper Xtreme D4 2133
    GPU: nVidia GTX 780 Reference
    • Ciarlatano's Full Spec's
      • Case:
      • Phanteks Evolv ATX
      • PSU:
      • be quiet! DPP 10 1000W
      • Cooling:
      • EKWB Supremacy EVO, Swiftech Komodo NV-LE, D5 PWM Monsoon MMRS HWL Nemesis 360GTS 3 Phanteks F120MP, 3 Phanteks F140SP
      • Sound:
      • ASUS Essence STX
      • Monitor:
      • ASUS 24"
      • OS:
      • Windows 7 64
    Thanks
    3
    Thanked 122 Times in 105 Posts
    Points: 20,344, Level: 43
    Points: 20,344, Level: 43
    Level completed: 55%,
    Points required for next Level: 406
    Level completed: 55%, Points required for next Level: 406
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    Quote Originally Posted by terrelljames91 View Post
    Just strange the card works in safe mode, and before driver update... I have never seen this before.
    So...I hate to ask the most obvious question possible....but why haven't you simply gone back to the old driver?

  13. The following user thanks Ciarlatano For this above post:

    vinman (16-10-2014)

  14. #13
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    Quote Originally Posted by Ciarlatano View Post
    So...I hate to ask the most obvious question possible....but why haven't you simply gone back to the old driver?

    New cards, New drivers... I picked the most recent one tho, I guess it won't hurt to download an older driver... All the other cards work fine by themselves tho

  15. #14
    Core Member

    Status
    Ciarlatano is offline

    Last Online
    08-09-2017 @ 13:12
    Join Date
    Dec 2011
    Location
    NYC Metro Area
    Posts
    816
    CPU: Intel 4790K @ 4.6GHz
    M/B: ASUS Z97 Sabertooth
    RAM: 16GB Patriot Viper Xtreme D4 2133
    GPU: nVidia GTX 780 Reference
    • Ciarlatano's Full Spec's
      • Case:
      • Phanteks Evolv ATX
      • PSU:
      • be quiet! DPP 10 1000W
      • Cooling:
      • EKWB Supremacy EVO, Swiftech Komodo NV-LE, D5 PWM Monsoon MMRS HWL Nemesis 360GTS 3 Phanteks F120MP, 3 Phanteks F140SP
      • Sound:
      • ASUS Essence STX
      • Monitor:
      • ASUS 24"
      • OS:
      • Windows 7 64
    Thanks
    3
    Thanked 122 Times in 105 Posts
    Points: 20,344, Level: 43
    Points: 20,344, Level: 43
    Level completed: 55%,
    Points required for next Level: 406
    Level completed: 55%, Points required for next Level: 406
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    Quote Originally Posted by terrelljames91 View Post
    New cards, New drivers... I picked the most recent one tho, I guess it won't hurt to download an older driver... All the other cards work fine by themselves tho
    So.....do the cards work in safe mode? I am talking strictly about the new cards.

  16. #15
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    Quote Originally Posted by Ciarlatano View Post
    So.....do the cards work in safe mode? I am talking strictly about the new cards.
    Yes it does

  17. #16
    Regular Member

    Status
    terrelljames91 is offline

    Last Online
    17-05-2015 @ 02:12
    Join Date
    May 2013
    Location
    New York
    Posts
    151
    CPU: I7 4790k
    M/B: Asus Hero vii
    RAM: 8gigs Corsair Vengance 1600
    GPU: R9 290x
    • terrelljames91's Full Spec's
      • Case:
      • NZXT Switch 810
      • PSU:
      • X4 1050watt
      • Cooling:
      • Laing D5 Blackice Stealth 420 Rad Swiftech apogee XL 6 Bblaster 140mm fans push/pull
      • Monitor:
      • Samsung synchmasters27b350
      • OS:
      • windows 7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Points: 2,247, Level: 13
    Points: 2,247, Level: 13
    Level completed: 33%,
    Points required for next Level: 203
    Level completed: 33%, Points required for next Level: 203
    Overall activity: 0%
    Overall activity: 0%

    Default Re: New GPU, Black screen after update. Help

    I'm booted into Windows on the card right now... I have NO drivers installed... If I install the current driver off of AMD website I will get no display.... I am going to try and install the drivers that are on the CD that it comes with

Page 1 of 2 1 2 LastLast

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 12
    Last Post: 12-04-2014, 19:52
  2. HD 6850 screen goes black, freezes pc
    By criss_glitch666 in forum Graphics Cards
    Replies: 39
    Last Post: 26-02-2012, 18:57
  3. 4850 freezing & black screen help
    By camcafe in forum Video Card Overclocking
    Replies: 17
    Last Post: 12-11-2008, 12:12
  4. cod4 screen going black at startup
    By srice425 in forum PC Games
    Replies: 2
    Last Post: 15-10-2008, 09:38
  5. Black screen before log on
    By PressESCtoquiT in forum General Hardware
    Replies: 7
    Last Post: 12-10-2006, 13:21

Search tags for this page

There are currently no search tags.
Click on a term to search for related topics.

Tags for this Thread