motherboards
Arctic
Arctic Feezer 7x
Results 1 to 12 of 12

Thread: Monitor wont turn on

  1. #1
    Regular Member

    Status
    Gareth is offline

    Last Online
    07-06-2010 @ 08:02
    Join Date
    Jul 2006
    Location
    Cambridgeshire, England
    Posts
    1,703
    CPU: Intel Core 2 Quad Q9450 / 3.30GHz
    M/B: ASUS P5Q-E
    RAM: 8.00GB DDR2 1066 PC8500
    GPU: Powercolor Radeon HD4870 1GB GDDR5 800MHz/3,700MHz + GeForce 8600GT
    • Gareth's Full Spec's
      • Case:
      • NZXT Whisper Series Classic
      • PSU:
      • 730W Hiper
      • Cooling:
      • Thermaltake V-14 Pro 3x 120mm intake 1x 120mm exhaust 2x 80mm exhaust
      • Sound:
      • Soundblaster Audigy SE
      • Monitor:
      • Packard Bell Viseo 230Ws 1920x1080 + AOC 22" 1680x1050 + Mag Innovisions 19" 1440x900
      • OS:
      • Windows 7 Professional x64
    Thanks
    34
    Thanked 20 Times in 20 Posts
    Points: 13,481, Level: 35
    Points: 13,481, Level: 35
    Level completed: 19%,
    Points required for next Level: 569
    Level completed: 19%, Points required for next Level: 569
    Overall activity: 99.0%
    Overall activity: 99.0%

    Default Monitor wont turn on

    Hey all, I have sitting with me, a dead LCD monitor, it however, will not turn on. When I plug in the LCD, the monitor blue power light flashes frequently, and its just that. I contacted Proview, and they said I had no warranty and said there is nothing they can do about it So, does anybody know any way I can bring an old LCD back to life?

    Its a 19" Widescreen.


    Also, is it safe to open them up?

  2. #2
    Regular Member

    Status
    say what is offline

    Last Online
    05-02-2017 @ 17:13
    Join Date
    Apr 2006
    Location
    Florida
    Posts
    1,452
    CPU: i7-4790k @ 4.7
    M/B: Gigabyte Z97X Gaming 5
    RAM: 16 GB G.SKILL Ripjaws Z 2400MHz @stock timings
    GPU: Gigabyte GTX 1080
    • say what's Full Spec's
      • Case:
      • Cooler Master HAF XB Evo
      • PSU:
      • Evga 750 Something or another, Its full modular
      • Cooling:
      • Water
      • Monitor:
      • Acer 24 inch 144 Hz
      • OS:
      • Windows 10
    Thanks
    33
    Thanked 48 Times in 46 Posts
    Points: 15,142, Level: 37
    Points: 15,142, Level: 37
    Level completed: 37%,
    Points required for next Level: 508
    Level completed: 37%, Points required for next Level: 508
    Overall activity: 56.0%
    Overall activity: 56.0%

    Default

    it wont turn on all together, or when its plugged in to your computer
    What?

  3. #3
    Regular Member

    Status
    Gareth is offline

    Last Online
    07-06-2010 @ 08:02
    Join Date
    Jul 2006
    Location
    Cambridgeshire, England
    Posts
    1,703
    CPU: Intel Core 2 Quad Q9450 / 3.30GHz
    M/B: ASUS P5Q-E
    RAM: 8.00GB DDR2 1066 PC8500
    GPU: Powercolor Radeon HD4870 1GB GDDR5 800MHz/3,700MHz + GeForce 8600GT
    • Gareth's Full Spec's
      • Case:
      • NZXT Whisper Series Classic
      • PSU:
      • 730W Hiper
      • Cooling:
      • Thermaltake V-14 Pro 3x 120mm intake 1x 120mm exhaust 2x 80mm exhaust
      • Sound:
      • Soundblaster Audigy SE
      • Monitor:
      • Packard Bell Viseo 230Ws 1920x1080 + AOC 22" 1680x1050 + Mag Innovisions 19" 1440x900
      • OS:
      • Windows 7 Professional x64
    Thanks
    34
    Thanked 20 Times in 20 Posts
    Points: 13,481, Level: 35
    Points: 13,481, Level: 35
    Level completed: 19%,
    Points required for next Level: 569
    Level completed: 19%, Points required for next Level: 569
    Overall activity: 99.0%
    Overall activity: 99.0%

    Default

    Wont turn on all together. Even on multiple PCs.

  4. #4
    Regular Member

    Status
    smith is offline

    Last Online
    29-03-2010 @ 17:40
    Join Date
    Dec 2006
    Posts
    991
    CPU: E6600 at 3.6ghz
    M/B: Maximus Formula SE
    RAM: mushkin redline xp2-8000 @ 960mhz 4-4-4-8 1T
    GPU: HIS 4870 Xfire 830/1000
    Thanks
    5
    Thanked 9 Times in 9 Posts
    Points: 5,855, Level: 22
    Points: 5,855, Level: 22
    Level completed: 61%,
    Points required for next Level: 195
    Level completed: 61%, Points required for next Level: 195
    Overall activity: 76.0%
    Overall activity: 76.0%

    Default

    well lcd's dont have mecury in them so i dont see why (if it is already broken) you shouldnt open it, good luck fixing it though lol.

  5. #5
    OC Jedi Master

    Status
    Deton is offline

    Last Online
    27-02-2014 @ 22:13
    Join Date
    Dec 2006
    Location
    Canada
    Posts
    8,493
    CPU: i7 920, 4.2Ghz HT
    M/B: P6X58D Premium
    RAM: OCZ Flex EX PC3-17000 12GB
    GPU: Asus EAH5870
    • Deton's Full Spec's
      • Case:
      • Lian Li A70F
      • PSU:
      • Enermax Galaxy Evo 1250W
      • Cooling:
      • Custom H20 setup.
      • Sound:
      • Onboard
      • Monitor:
      • ViewSonic VX2435
      • OS:
      • Win 7 - 64bit
    Thanks
    45
    Thanked 1,179 Times in 1,026 Posts
    Points: 50,246, Level: 69
    Points: 50,246, Level: 69
    Level completed: 36%,
    Points required for next Level: 904
    Level completed: 36%, Points required for next Level: 904
    Overall activity: 7.0%
    Overall activity: 7.0%

    Default

    maybe you can try CPR
    R.I.P

  6. #6
    Regular Member

    Status
    Gareth is offline

    Last Online
    07-06-2010 @ 08:02
    Join Date
    Jul 2006
    Location
    Cambridgeshire, England
    Posts
    1,703
    CPU: Intel Core 2 Quad Q9450 / 3.30GHz
    M/B: ASUS P5Q-E
    RAM: 8.00GB DDR2 1066 PC8500
    GPU: Powercolor Radeon HD4870 1GB GDDR5 800MHz/3,700MHz + GeForce 8600GT
    • Gareth's Full Spec's
      • Case:
      • NZXT Whisper Series Classic
      • PSU:
      • 730W Hiper
      • Cooling:
      • Thermaltake V-14 Pro 3x 120mm intake 1x 120mm exhaust 2x 80mm exhaust
      • Sound:
      • Soundblaster Audigy SE
      • Monitor:
      • Packard Bell Viseo 230Ws 1920x1080 + AOC 22" 1680x1050 + Mag Innovisions 19" 1440x900
      • OS:
      • Windows 7 Professional x64
    Thanks
    34
    Thanked 20 Times in 20 Posts
    Points: 13,481, Level: 35
    Points: 13,481, Level: 35
    Level completed: 19%,
    Points required for next Level: 569
    Level completed: 19%, Points required for next Level: 569
    Overall activity: 99.0%
    Overall activity: 99.0%

    Default

    I opened it up, and had no idea what I was looking at, lol. I think its a blown circuit board?

  7. #7
    Core Member

    Status
    intex is offline

    Last Online
    20-04-2009 @ 02:46
    Join Date
    Nov 2007
    Location
    US - Washington State
    Posts
    104
    CPU: AMD am2 6000+ x2 3.0ghz
    M/B: Asus M2n32 sli deluxe Wireless
    RAM: 4 Gb G.skill 4-4-3-5-12t
    GPU: Msi 8800 ultra O.C. 700\1180
    • intex's Full Spec's
      • Case:
      • DD Water Box Plus
      • PSU:
      • Xion 800 modular Sli Certified
      • Cooling:
      • D5 Variable Speed pump, Tygon 1/2 Inner diameter tubing, DD 120.2 Black ice Pro rad, Dual Silver stone 110 cfm 120mm Fans, Danger den TDX MultiCore CPU block, DD 8800 ultra GPU Block.
      • Sound:
      • Creative X-fi Xtreme Gamer - Razer Barracuda Head set.
      • Monitor:
      • 22in Samsung 2ms 226bw
      • OS:
      • Vista ultimate 64
      • Misc:
      • logitech g15 lcd and Copperhead. Logitech 5.1 Surround. Aspen Home L executive Desk.
    Thanks
    1
    Thanked 1 Time in 1 Post
    Points: 3,246, Level: 16
    Points: 3,246, Level: 16
    Level completed: 49%,
    Points required for next Level: 204
    Level completed: 49%, Points required for next Level: 204
    Overall activity: 48.0%
    Overall activity: 48.0%

    Default

    Quote Originally Posted by Gareth Hale View Post
    I opened it up, and had no idea what I was looking at, lol. I think its a blown circuit board?

    check to see if there are any burnt fuses, then I'd check for any burn or melting anywhere inside, and if you cant find either, look to see if there are any wires that have become disconnected. Ive bought broken tv's and theese were the most common issues,

  8. #8
    Regular Member

    Status
    Gareth is offline

    Last Online
    07-06-2010 @ 08:02
    Join Date
    Jul 2006
    Location
    Cambridgeshire, England
    Posts
    1,703
    CPU: Intel Core 2 Quad Q9450 / 3.30GHz
    M/B: ASUS P5Q-E
    RAM: 8.00GB DDR2 1066 PC8500
    GPU: Powercolor Radeon HD4870 1GB GDDR5 800MHz/3,700MHz + GeForce 8600GT
    • Gareth's Full Spec's
      • Case:
      • NZXT Whisper Series Classic
      • PSU:
      • 730W Hiper
      • Cooling:
      • Thermaltake V-14 Pro 3x 120mm intake 1x 120mm exhaust 2x 80mm exhaust
      • Sound:
      • Soundblaster Audigy SE
      • Monitor:
      • Packard Bell Viseo 230Ws 1920x1080 + AOC 22" 1680x1050 + Mag Innovisions 19" 1440x900
      • OS:
      • Windows 7 Professional x64
    Thanks
    34
    Thanked 20 Times in 20 Posts
    Points: 13,481, Level: 35
    Points: 13,481, Level: 35
    Level completed: 19%,
    Points required for next Level: 569
    Level completed: 19%, Points required for next Level: 569
    Overall activity: 99.0%
    Overall activity: 99.0%

    Default

    I can't seem to see anything, I think it just died?

  9. #9
    Core Member

    Status
    intex is offline

    Last Online
    20-04-2009 @ 02:46
    Join Date
    Nov 2007
    Location
    US - Washington State
    Posts
    104
    CPU: AMD am2 6000+ x2 3.0ghz
    M/B: Asus M2n32 sli deluxe Wireless
    RAM: 4 Gb G.skill 4-4-3-5-12t
    GPU: Msi 8800 ultra O.C. 700\1180
    • intex's Full Spec's
      • Case:
      • DD Water Box Plus
      • PSU:
      • Xion 800 modular Sli Certified
      • Cooling:
      • D5 Variable Speed pump, Tygon 1/2 Inner diameter tubing, DD 120.2 Black ice Pro rad, Dual Silver stone 110 cfm 120mm Fans, Danger den TDX MultiCore CPU block, DD 8800 ultra GPU Block.
      • Sound:
      • Creative X-fi Xtreme Gamer - Razer Barracuda Head set.
      • Monitor:
      • 22in Samsung 2ms 226bw
      • OS:
      • Vista ultimate 64
      • Misc:
      • logitech g15 lcd and Copperhead. Logitech 5.1 Surround. Aspen Home L executive Desk.
    Thanks
    1
    Thanked 1 Time in 1 Post
    Points: 3,246, Level: 16
    Points: 3,246, Level: 16
    Level completed: 49%,
    Points required for next Level: 204
    Level completed: 49%, Points required for next Level: 204
    Overall activity: 48.0%
    Overall activity: 48.0%

    Default

    EDIT : was dumb
    Last edited by intex; 29-02-2008 at 03:05.

  10. #10
    Core Member

    Status
    intex is offline

    Last Online
    20-04-2009 @ 02:46
    Join Date
    Nov 2007
    Location
    US - Washington State
    Posts
    104
    CPU: AMD am2 6000+ x2 3.0ghz
    M/B: Asus M2n32 sli deluxe Wireless
    RAM: 4 Gb G.skill 4-4-3-5-12t
    GPU: Msi 8800 ultra O.C. 700\1180
    • intex's Full Spec's
      • Case:
      • DD Water Box Plus
      • PSU:
      • Xion 800 modular Sli Certified
      • Cooling:
      • D5 Variable Speed pump, Tygon 1/2 Inner diameter tubing, DD 120.2 Black ice Pro rad, Dual Silver stone 110 cfm 120mm Fans, Danger den TDX MultiCore CPU block, DD 8800 ultra GPU Block.
      • Sound:
      • Creative X-fi Xtreme Gamer - Razer Barracuda Head set.
      • Monitor:
      • 22in Samsung 2ms 226bw
      • OS:
      • Vista ultimate 64
      • Misc:
      • logitech g15 lcd and Copperhead. Logitech 5.1 Surround. Aspen Home L executive Desk.
    Thanks
    1
    Thanked 1 Time in 1 Post
    Points: 3,246, Level: 16
    Points: 3,246, Level: 16
    Level completed: 49%,
    Points required for next Level: 204
    Level completed: 49%, Points required for next Level: 204
    Overall activity: 48.0%
    Overall activity: 48.0%

    Default

    Quote Originally Posted by Gareth Hale View Post
    Hey all, I have sitting with me, a dead LCD monitor, it however, will not turn on. When I plug in the LCD, the monitor blue power light flashes frequently, and its just that. I contacted Proview, and they said I had no warranty and said there is nothing they can do about it So, does anybody know any way I can bring an old LCD back to life?

    Its a 19" Widescreen.


    Also, is it safe to open them up?

    I just realized soemthing, have you tried multiple dvi ccables? or hook it up with analog if it has one, A lot of monitors will sit at a black screen and flash the power led if there is no signal...

  11. #11
    Regular Member

    Status
    Gareth is offline

    Last Online
    07-06-2010 @ 08:02
    Join Date
    Jul 2006
    Location
    Cambridgeshire, England
    Posts
    1,703
    CPU: Intel Core 2 Quad Q9450 / 3.30GHz
    M/B: ASUS P5Q-E
    RAM: 8.00GB DDR2 1066 PC8500
    GPU: Powercolor Radeon HD4870 1GB GDDR5 800MHz/3,700MHz + GeForce 8600GT
    • Gareth's Full Spec's
      • Case:
      • NZXT Whisper Series Classic
      • PSU:
      • 730W Hiper
      • Cooling:
      • Thermaltake V-14 Pro 3x 120mm intake 1x 120mm exhaust 2x 80mm exhaust
      • Sound:
      • Soundblaster Audigy SE
      • Monitor:
      • Packard Bell Viseo 230Ws 1920x1080 + AOC 22" 1680x1050 + Mag Innovisions 19" 1440x900
      • OS:
      • Windows 7 Professional x64
    Thanks
    34
    Thanked 20 Times in 20 Posts
    Points: 13,481, Level: 35
    Points: 13,481, Level: 35
    Level completed: 19%,
    Points required for next Level: 569
    Level completed: 19%, Points required for next Level: 569
    Overall activity: 99.0%
    Overall activity: 99.0%

    Default

    Nope, once plugged into any PC, the blue lights continues to flash repeatedly, I can only use VGA however, as that is only what it has. I am not too sure what to do on it now.

  12. #12
    Core Member

    Status
    intex is offline

    Last Online
    20-04-2009 @ 02:46
    Join Date
    Nov 2007
    Location
    US - Washington State
    Posts
    104
    CPU: AMD am2 6000+ x2 3.0ghz
    M/B: Asus M2n32 sli deluxe Wireless
    RAM: 4 Gb G.skill 4-4-3-5-12t
    GPU: Msi 8800 ultra O.C. 700\1180
    • intex's Full Spec's
      • Case:
      • DD Water Box Plus
      • PSU:
      • Xion 800 modular Sli Certified
      • Cooling:
      • D5 Variable Speed pump, Tygon 1/2 Inner diameter tubing, DD 120.2 Black ice Pro rad, Dual Silver stone 110 cfm 120mm Fans, Danger den TDX MultiCore CPU block, DD 8800 ultra GPU Block.
      • Sound:
      • Creative X-fi Xtreme Gamer - Razer Barracuda Head set.
      • Monitor:
      • 22in Samsung 2ms 226bw
      • OS:
      • Vista ultimate 64
      • Misc:
      • logitech g15 lcd and Copperhead. Logitech 5.1 Surround. Aspen Home L executive Desk.
    Thanks
    1
    Thanked 1 Time in 1 Post
    Points: 3,246, Level: 16
    Points: 3,246, Level: 16
    Level completed: 49%,
    Points required for next Level: 204
    Level completed: 49%, Points required for next Level: 204
    Overall activity: 48.0%
    Overall activity: 48.0%

    Default

    oh i sry

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Computer wont turn on
    By azzkitect in forum General Hardware
    Replies: 4
    Last Post: 05-12-2017, 09:14
  2. Replies: 14
    Last Post: 22-08-2010, 11:51
  3. Computer wont turn on
    By criss_glitch666 in forum General Hardware
    Replies: 12
    Last Post: 26-07-2009, 23:40
  4. Monitor Won't Turn on After Computer Wakes Up
    By seamless in forum Monitors
    Replies: 4
    Last Post: 06-07-2009, 14:05
  5. Turn Off Xfire...How?
    By grumpydaddy in forum Video Card Overclocking
    Replies: 1
    Last Post: 23-08-2008, 21:10

Search tags for this page

aoc e2343 does not turn on
,
aoc l19w89v won't power on
,
aoc monitor blinking blue light
,
aoc monitor blue light flashing
,
aoc monitor not turning on
,
aoc monitor power light flashes
,
aoc monitor wont start up
,

aoc monitor wont turn on

,
asus monitor won't turn on
,
how to turn on an aoc monitor
,
how to turn on aoc monitor
,
how to turn on asus monitor
,
my aoc monitor wont turn on
,
proview monitor problems
Click on a term to search for related topics.

Tags for this Thread